Memory leak of DOM windows

RESOLVED WORKSFORME

Status

()

--
minor
RESOLVED WORKSFORME
11 years ago
11 years ago

People

(Reporter: gkw, Assigned: sayrer)

Tracking

({memory-leak, qawanted})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a9pre) Gecko/2007101604 Minefield/3.0a9pre

A memory leak occurred after using Minefield latest nightly, following steps
below:


Reproducible: Always

Steps to Reproduce:
1. Start Minefield.
2. Mouse-click the top left red button to close the current window. (Minefield's options are still present in Mac OS X menu area)
3. Mouse-click Tools -> Error Console. Leave the window open.
4. Mouse-click Bookmarks -> Organize Bookmarks. Leave the window open.
5. Mouse-click Tools -> Downloads. Leave the window open.
6. Mouse-click Minefield -> Preferences. Leave the window open.
7. Mouse-click Minefield -> Quit Minefield.

Actual Results:  
Leaked inner window 1be47980 (outer 1a711270) at address 1be47980.
 ... with URI "about:blank".
Leaked outer window 16d12980 at address 16d12980.
Leaked outer window 1a711270 at address 1a711270.
Leaked inner window 1dccea0 (outer 16d12980) at address 1dccea0.
 ... with URI "chrome://browser/content/hiddenWindow.xul".
Summary:
Leaked 4 out of 17 DOM Windows
Leaked 0 out of 58 documents
Leaked 0 out of 8 docshells

Expected Results:  
Summary:
Leaked 0 out of 17 DOM Windows
Leaked 0 out of 58 documents
Leaked 0 out of 8 docshells

(Please use the mouse to click the options; I was unable to reproduce the problem by using the keyboard shortcuts)
(Reporter)

Updated

11 years ago
Keywords: mlk
(Reporter)

Updated

11 years ago
Flags: blocking-firefox3?
(Assignee)

Updated

11 years ago
Assignee: nobody → sayrer
Needs confirmation before we'll block on this.
Flags: blocking-firefox3?
Keywords: qawanted
(Reporter)

Comment 2

11 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a9pre) Gecko/2007102004 Minefield/3.0a9pre

reproduced using keyboard shortcuts (at all steps except the error console step)

this problem sometimes occurs when the preferences window is not opened (step 6 is skipped), but always occurs when step 6 is done.


if preferences window is not opened, the error shown is:

Leaked outer window 16c14840 at address 16c14840.
Leaked inner window 1e96b6f0 (outer 54d900) at address 1e96b6f0.
 ... with URI "about:blank".
Leaked outer window 54d900 at address 54d900.
Leaked inner window 1dcd1a0 (outer 16c14840) at address 1dcd1a0.
 ... with URI "chrome://browser/content/hiddenWindow.xul".

Summary:
Leaked 4 out of 15 DOM Windows
Leaked 0 out of 52 documents
Leaked 0 out of 7 docshells
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 3

11 years ago
I'm not seeing this. What extensions are installed?
(Reporter)

Comment 4

11 years ago
fresh profile. the keyboard shortcuts situation apparently is erratic; sometimes it works properly (no leakage) other times it still leaks.

Mouse-clicking definitely still leaks.

shifting back to error console reveals:

"Error: [Exception... "'Component does not have requested interface' when calling method: [nsIInterfaceRequestor::getInterface]"  nsresult: "0x80004002 (NS_NOINTERFACE)"  location: "<unknown>"  data: no]"

after pressing the organise bookmarks option at step 4. Might this be related?
(Reporter)

Comment 5

11 years ago
WFM as of:

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9a9pre) Gecko/2007110304 Minefield/3.0a9pre

(can't seem to reproduce the leaking anymore)
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.