Minefield doesn't quit when some modal dialogs are open

RESOLVED DUPLICATE of bug 400479

Status

()

Firefox
General
P4
major
RESOLVED DUPLICATE of bug 400479
11 years ago
11 years ago

People

(Reporter: gkw, Unassigned)

Tracking

unspecified
Firefox 3 beta3
x86
Mac OS X
Points:
---
Bug Flags:
blocking-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a9pre) Gecko/2007101604 Minefield/3.0a9pre

Summary says it all. If I close the remaining preferences window, Minefield will close. If I open a new window, I can actually continue surfing as if I hadn't tried quitting before.

Reproducible: Always

Steps to Reproduce:
1. Open Minefield, then preferences.
2A. Under Content, click that lone button in the languages section (I can't see the name; it's another UI bug I suppose.)
OR
2B. Under Advanced -> Encryption -> click Validation.
OR
2C. Under Advanced -> Network -> click Settings.
3. Go to Minefield menu and select "Quit Minefield".

3.
Actual Results:  
The webpage window will close along with the sub-preferences windows; except the main preferences. Minefield doesn't quit.

Expected Results:  
Minefield should quit properly.

Only certain menus exhibit this behaviour. Other menus, such as Advanced -> Encryption -> View Certificates, do not have this problem and in these cases Minefield quits properly.

If this helps, leak-gauge.pl shows:

CGBitmapContextCreateImage: invalid context

multiple times when the Quit command is pressed.
(Reporter)

Updated

11 years ago
Flags: blocking-firefox3?
I've seen this sometimes when I'm applying an update, and am asked to restart, but then get a content window spawning a JS alert (generally spawned by onBeforeClose() in Zimbra) ... when I confirm that alert, all Minefield windows close but I need to give it another quit command (either by right-clicking the dock icon or cmd-Q) for it to really take hold. Might be related.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-firefox3? → blocking-firefox3+
(In reply to comment #1)
> I've seen this sometimes when I'm applying an update, and am asked to restart,
> but then get a content window spawning a JS alert (generally spawned by
> onBeforeClose() in Zimbra) ... when I confirm that alert, all Minefield windows
> close but I need to give it another quit command (either by right-clicking the
> dock icon or cmd-Q) for it to really take hold. Might be related.

That's bug 399447.

Updated

11 years ago
Target Milestone: --- → Firefox 3 M11

Updated

11 years ago
Priority: -- → P5

Updated

11 years ago
Priority: P5 → P3
Summary: Minefield doesn't quit when certain pref windows within main preferences are opened → Minefield doesn't quit when some modal dialogs are open

Updated

11 years ago
Target Milestone: Firefox 3 Mx → Firefox 3 M11
(Reporter)

Comment 3

11 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b3pre) Gecko/2008010619 Minefield/3.0b3pre

Running a debug Minefield build (compiled from cvs), when I run through procedures 2A, 2B or 2C, I encounter this error in the debug output once I click quit Minefield in step 3 when using gdb
(http://kb.mozillazine.org/Getting_a_stacktrace_with_gdb):


JavaScript error: , line 0: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIAppStartup.quit]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://global/content/globalOverlay.js :: goQuitApplication :: line 51"  data: no]

(Reporter)

Comment 4

11 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b3) Gecko/2008020511 Firefox/3.0b3

Still seeing this with Firefox 3 Beta 3, running through procedure 2B.

Updated

11 years ago
Priority: P3 → P4

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 400479
You need to log in before you can comment on or make changes to this bug.