Last Comment Bug 400051 - problem with public calendars on iCalX
: problem with public calendars on iCalX
Status: RESOLVED DUPLICATE of bug 387559
:
Product: Calendar
Classification: Client Software
Component: Provider: ICS/WebDAV (show other bugs)
: unspecified
: x86 Windows XP
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-16 12:52 PDT by Michal Kaut
Modified: 2007-10-16 14:07 PDT (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Michal Kaut 2007-10-16 12:52:46 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7
Build Identifier: both Sunbird 0.5 and Lightning 0.5 

An attempt to create a new event in a public calendar posted on iCalX.com causes the following:
- all calendar events disappear once one changes the view (month etc)
- the calendars won't reload (possibly related to 386326 bug?)
- Thunderbird and/or Sunbird process does not terminate after closing the application (could be related to the 378578 bug?)

The problem appeared perhaps a month ago, can't say exactly.

Reproducible: Always

Steps to Reproduce:
1. Subscribe to a previously created .ics calendar posted as "public" on iCalX.com 
2. Add an event to the calendar in Lightning or Sunbird
3. Change a month/week one step forward and back
Actual Results:  
All events disappear (even local calendars), calendars won't reload.
In addition, closing the application won't terminate the process.

Expected Results:  
Nothing visible, once the event has been added.

The error message is as follows:
Error: [Exception... "Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIHttpChannel.requestSucceeded]"  nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)"  location: "JS frame :: file:///C:/Documents%20and%20Settings/kaut/Application%20Data/Thunderbird/Profiles/wycapb3b.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calICSCalendar.js :: anonymous :: line 383"  data: no]
Source File: file:///C:/Documents%20and%20Settings/kaut/Application%20Data/Thunderbird/Profiles/wycapb3b.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calICSCalendar.js
Line: 383

My guess: iCalX public calendars do not need password for subscribe and read, but need one for writing. Calendar gets confused by being able to subscribe and load the calendar without a password ... just a guess
It works with private calendars, i.e. calendars with password for both read and write.

It is, of course, possible that the error is on the iCalX side...
Comment 1 Omar Bajraszewski 2007-10-16 13:24:53 PDT
(In reply to comment #0)
>
> 
> An attempt to create a new event in a public calendar posted on iCalX.com


But you cannot add an event to public calendar. It can only be viewed or subscribed
Comment 2 Simon Paquet [:sipaq] 2007-10-16 14:07:49 PDT

*** This bug has been marked as a duplicate of bug 387559 ***

Note You need to log in before you can comment on or make changes to this bug.