update forwarding URL for sfx affiliates program

RESOLVED FIXED

Status

Websites Graveyard
spreadfirefox.com
RESOLVED FIXED
11 years ago
7 years ago

People

(Reporter: asa, Assigned: David Rolnitzky)

Tracking

Details

(Reporter)

Description

11 years ago
Right now, the SFX affiliates module forwards affiliate traffic to http://getfirefox.com which in turn forwards the traffic to http://www.mozilla.com/firefox/  The problem with this is that there is nothing preserved here about the source of the click because getfirefox.com gets the referral "credit" rather than spreadfirefox.com.  getfirefox.com forwards to http://www.mozilla.com/firefox/?from=getfirefox so I'm proposing that we just skip getfirefox.com and from the affiliates module at SFX simply forward to http://www.mozilla.com/firefox/?from=sfx.

Unless anyone can think of a reason to not do this, Paul, can you update the SFX Affiliates module on the live site and on the dev site to the new URL?

Comment 1

11 years ago
Ill investigate this first thing in the morning Asa  .
(Assignee)

Comment 2

11 years ago
This will really help to validate traffic quantities originating from sfx to mozilla.com

Comment 3

11 years ago
Hi Asa / David

I have made the change to SFX2 . The changes to the production site will come
into play as soon as the bug
https://bugzilla.mozilla.org/show_bug.cgi?id=400128 is actioned .

Do you think the spreadfirefox affiliate referral link should redirect them to
a spreadfirefox page which loads in the browser and from which they can  find
out about the spreadfirefox campaign and click on a link to get firefox. I am
thinking that we will want to every
satisfied firefox user to come over to the spreadfirefox site that they
remembered seeing while downloading firefox .


Regards Paul
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

11 years ago
Clicking on Firefox (SFX affiliates) banners causes an error and does not send
a user on to the download page. This is the error message I get when clicking
on an affiliate banner on my own site:

Column count doesn't match value count at row 1
DEBUG: INSERT INTO affiliates
VALUES(NULL,'89185','a341b4c0324a13edff5e7a3c7f8409f9','10.2.81.4','http://www.7is7.com/','197',UNIX_TIMESTAMP(NOW()),'N')
LINE: 220
FILE: /data/www/www.spreadfirefox.com/helper_scripts/db.php
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 5

11 years ago
seems to be working again. i wonder what that was.

Comment 6

11 years ago
Hi Asa ,

There is a problem which looks to have be caused by me .

It happens the first time and not subsequently because we only 
capture an affiliate referral once from a given IP in any 24 hour period.

The problem looks to have arisen while i was deleting a duplicate "INSERT INTO affilates" that was generated by CVS because of a collision. 

I have corrected the problem but i can't  commit my changes into CVS

 paulbookers-computer:~/networksolutions/paulbooker paulbooker$ ssh-agent /bin/bash  
paulbookers-computer:~/networksolutions/paulbooker paulbooker$ ssh-add 
Enter passphrase for /Users/paulbooker/.ssh/id_dsa: 
Identity added: /Users/paulbooker/.ssh/id_dsa (/Users/paulbooker/.ssh/id_dsa)
paulbookers-computer:~/networksolutions/paulbooker paulbooker$ ssh paul@willow.mozilla.org
Last login: Mon Oct 22 06:40:32 2007 from 80-194-160-160.cable.ubr06.wals.blueyonder.co.uk
[paul@willow-vm ~]$ cd spreadfirefox

[paul@willow-vm spreadfirefox]$ cvs commit affiliates.php 
Permission denied (publickey,gssapi-with-mic).
cvs [commit aborted]: end of file from server (consult above messages if any)
[paul@willow-vm spreadfirefox]$ cvs up
Permission denied (publickey,gssapi-with-mic).
cvs [update aborted]: end of file from server (consult above messages if any)
[paul@willow-vm spreadfirefox]$ cvs update
Permission denied (publickey,gssapi-with-mic).
cvs [update aborted]: end of file from server (consult above messages if any)

Please would you investgate by public key problem .


Thanks Paul

(Reporter)

Comment 7

11 years ago
Morgamic, we need these changes checked in ASAP. This is a critical system. Can someone on your team make this change while we figure out what's going on with paul's account?

Comment 8

11 years ago
that should have been ..

ssh -A paul@willow.mozilla.org (PC) (-A  forwards your authentication agent connection)


would you know push affilaites.php to the production server please 

thanks paul 

Comment 9

11 years ago
Would you also please delete my affiliate referral records from IP 80.194.160.160 so that i can confirm that the problem is resolved .

(Assignee)

Comment 10

11 years ago
In re: the affiliate referral link going directly to a spreadfirefox page -- if it can handle the traffic, I think this is a great idea.  This would also help our ability to track the effectiveness of the affiliate buttons on downloads.

(Reporter)

Comment 11

11 years ago
(In reply to comment #10)
> In re: the affiliate referral link going directly to a spreadfirefox page -- if
> it can handle the traffic, I think this is a great idea.  This would also help
> our ability to track the effectiveness of the affiliate buttons on downloads.
> 
I disagree. I don't think spreadfirefox should get in the business of hosting a primary download page. Aren't we trying to consolodate to one primary page at www.mozilla.com/firefox ? 
(Assignee)

Comment 12

11 years ago
Re: consolidating -- I don't think that we are necessarily trying to do this in the short-term (though with a site redesign this may happen).  The actual download files would be hosted in the same way, just the page would be in a different location.  We already have landing pages for different partners and programs that are not pointing at www.mozilla.com/firefox
Who would keep this new page up-to-date with the latest release and download links? We already have a tough enough time as it is keeping all our pages updated with the latest information, and adding another page on a separate site to this list of sites/pages-to-be-updated-at-each-release might not be a good idea in the long run.
(Reporter)

Comment 14

11 years ago
OK, let's move that discussion elsewhere. We have a bug here with the SFX affiliate program being broken! that deserves more attention than this issue.

Comment 15

11 years ago
Would you please help us in commiting our changes or let us know when you can make these changes .

Standing by .

Paul .

Updated

11 years ago
Assignee: paul → drolnitzky
Status: REOPENED → NEW

Comment 16

11 years ago
Would somebody please commit these changes

Standing by .

Paul
(Reporter)

Comment 17

11 years ago
Morgamic, Pkim, we're really seriously busted here. This is a primary channel for Firefox downloads and it's been hosed for some time and I'm concerned that it's not being seen as the priority that it is. 
Paul, what needs to happen -- upload the new affiliates.php?
http://bonsai-www.mozilla.org/cvslog.cgi?file=spreadfirefox/affiliates.php&rev=SFX_4_6_5&root=/www

It's already in CVS (2007-10-22 10:35), so I guess IT just needs to push it live?

Comment 20

11 years ago
Yes please push affilates.php live (as per comment 8)

You can still get me on skype @ paul.booker .

Comment 21

11 years ago
Standing by
CCing Staszyk because of the impact it may have on web stats analysis

Comment 23

11 years ago
Standing by .
This was pushed on Tuesday -- I thought you knew since the affiliates stuff works now (Asa said it looks fine).  Asa knew when it was pushed as well.  I guess nobody updated the bug.

For what it's worth, the "Standing by" comments don't really help much.  And for prod code pushes I thought you were already used to filing IT tickets?  That could have gotten a quicker response than posting those comments in a bug that wasn't in server ops -- just for future reference.

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → FIXED
(Reporter)

Comment 25

11 years ago
Is this going to need to be redone for http://newsfx.spreadfirefox.com ? 

Comment 26

11 years ago
The changes have already been pushed to the SFX2 Production site. 
Product: Websites → Websites Graveyard
You need to log in before you can comment on or make changes to this bug.