Closed Bug 400193 Opened 14 years ago Closed 10 years ago

[10.5] Bookmarks not imported correctly from Safari

Categories

(Firefox :: Migration, defect)

All
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 402964

People

(Reporter: jbecerra, Unassigned)

Details

(Keywords: polish, qawanted, ue)

If you import data from Safari using FF2008rc2 on Leopard a folder "From Safari" is added to the Bookmarks content in FF, but it is empty. Bookmarks added to the bookmarks toolbar in Safari seem to be imported correctly. On Tiger it works fine.
Flags: blocking1.8.1.9+
Summary: bookmarks not imported correctly from Safari (on Leopard) → [10.5] bookmarks not imported correctly from Safari (on Leopard)
Component: Bookmarks → Migration
QA Contact: bookmarks → migration
This WFM using  Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.8) Gecko/2007100816 Firefox/2.0.0.8. The first time I imported it did not bring in the ones I stored in the Safari BM toolbar, but that is expected. I then added some to the menu and they were imported fine (as were the Safari default bookmarks).
Using  Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.8) Gecko/2007100415 Firefox/2.0.0.8, here is what I saw with a fresh profile.

1. Launch Safari and add four new bookmarks to the bookmarks menu.
2. Launch a fresh instance of FF with a fresh profile.
3. File | Import.

Results:

FF imports the four new bookmarks I added with the designation "From Safari" and they are listed under Bookmarks. The default Safari bookmarks show up in the FF Bookmarks toolbar. In this test I did not add an bookmarks to the Safari Bookmarks toolbar.
qawanted: is this a reproducible problem or not? Don't see how it can block 1.8.1.12 if there's disagreement on that point. Plus we'll need to find someone with time to fix it.
Flags: blocking1.8.1.12+ → blocking1.8.1.12?
Keywords: qawanted
This Works for Me using FF 2.0.0.11 on Leopard 10.5.1. I got my Safari bookmarks on autoimport without any issues. 
Status: NEW → RESOLVED
Closed: 14 years ago
Flags: blocking1.8.1.12?
Resolution: --- → WORKSFORME
I can confirm this behavior with:

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b5pre) Gecko/2008030704 Minefield/3.0b5pre ID:2008030704.

Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12

The described behavior is a bit different under 10.4 and 10.5. Imported bookmarks from Safari are placed directly under the Bookmarks Toolbar instead putting them into the "From Safari" folder within the Bookmarks Menu. Under 10.4 the import folder is badly named "Imported IE Favorites".
Status: RESOLVED → REOPENED
Hardware: Macintosh → All
Resolution: WORKSFORME → ---
Summary: [10.5] bookmarks not imported correctly from Safari (on Leopard) → Bookmarks not imported correctly from Safari (on Leopard)
Version: 2.0 Branch → Trunk
Nominating for blocker, as per bug 413021.  I think this can cause major confusion with users who use the import wizard.

I will also install 10.4 on my system as soon as I find the install disc, to test this and see how we can resolve this.
Flags: blocking-firefox3?
Should the import actually import Safari's bookmarks toolbar straight into Firefox's toolbar? or should it go into a folder inside the Firefox toolbar?
(In reply to comment #7)
> Should the import actually import Safari's bookmarks toolbar straight into
> Firefox's toolbar? or should it go into a folder inside the Firefox toolbar?

I think that they shouldn't be placed directly under the Bookmarks Toolbar. Importing bookmarks from IE or other browser on different OS the bookmarks are stored in a sub folder of the Bookmarks Menu and not the Bookmarks Toolbar.

Has anyone checked what happens when importing bookmarks of Safari under Windows? Is it the same behavior? I could imagine.
Summary: Bookmarks not imported correctly from Safari (on Leopard) → [Mac] Bookmarks not imported correctly from Safari
(In reply to comment #8)
> Has anyone checked what happens when importing bookmarks of Safari under
> Windows? Is it the same behavior? I could imagine.

This is already covered by bug 421113. 

Not going to block, and not sure that it's even a bug, since the bookmark toolbar is a more prominent feature in Safari than it is in IE7, and their default bookmarks are actually kind of useful as opposed to IEs, which is (aiui) one of the reasons why we shoved IE's in a folder.
Flags: blocking-firefox3? → blocking-firefox3-
Keywords: polish, ue
Beltzner, but what should happen if I decide to reimport my Safari bookmarks at a later time when I've already filled my Bookmarks Toolbar with my own bookmarks? I don't want to see it cluttered with all the imported bookmarks from Safari. If they should be placed into a sub-folder then, we aren't consequent enough. 
Seems like a 10.5 only issue. I'm able to see this bug while running smoketests with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.7) Gecko/2009021906 Firefox/3.0.7
Summary: [Mac] Bookmarks not imported correctly from Safari → [10.5] Bookmarks not imported correctly from Safari
This is still reproducible with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090219 Minefield/3.2a1pre ID:20090219020624

There is no way to import the bookmarks from Safari on 10.5 if you miss this step by the initial profile creation. As Juan stated in comment 0 the Safari folder in the bookmarks is empty.
Flags: blocking-firefox3.1?
Comment 13 is not correct, sorry. All the bookmarks are places to the toolbar folder. Does not sound to be a blocker.
Flags: blocking-firefox3.1? → wanted-firefox3.1?
i agree
Status: REOPENED → RESOLVED
Closed: 14 years ago10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 402964
You need to log in before you can comment on or make changes to this bug.