Cookie Manager and Image Manager should be separate dialogs

VERIFIED FIXED in mozilla0.9

Status

()

P3
normal
VERIFIED FIXED
19 years ago
18 years ago

People

(Reporter: mpt, Assigned: morse)

Tracking

Trunk
mozilla0.9
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
This is split off from bug 35372.

The Cookie Manager and the Image Manager should be separate dialogs, rather than 
tabs in the same dialog. It makes little or no conceptual sense to put them in 
the same dialog.

Brendan, if you agree then please send to XPApps.
spam: adding self and tever to cc list.

Comment 2

19 years ago
Actually, I don't have a problem with those two managers sharing a dialog
conceptually.  In fact, I would argue for *more* managers sharing the same space
so that there'd be more of a one-stop shop for managing privacy and information.
 The problem is that the access mechanism (multiple, separate submenus which
contain both actions and dialog access with little or no differentiation)
doesn't support the same conceptual model since each manager is listed
separately and some *are* separate while others aren't.

Therefore, until such time as we decide to revisit both the access mechanism and
the managers themselves, I have to support separating the dialogs since there's
little benefit realized from their current combination.  Reassigning to XPApps.

See Bug <a href="http://bugzilla.mozilla.org/show_bug.cgi?id=32502">32502</a>
for related discussion on the access mechanism.
Assignee: bdonohoe → don
Component: User Interface: Design Feedback → XPApps
QA Contact: mpt → sairuh
over to to tever who handles cookies (cc'ing elig, who deals w/images).
QA Contact: sairuh → tever

Comment 4

19 years ago
cookies, morse.
Assignee: don → morse
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → Future
Component: XP Apps → Cookies

Comment 5

19 years ago
*** Bug 51156 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 6

18 years ago
Ben, you said you were interested in redoing this UI. Want a spec?
(Assignee)

Updated

18 years ago
Target Milestone: Future → M25
(Assignee)

Updated

18 years ago
Summary: Cookie Manager and Image Manager should be separate dialogs → [y]Cookie Manager and Image Manager should be separate dialogs
Target Milestone: M25 → ---

Comment 7

18 years ago
what does the [y] indicate?
(Assignee)

Updated

18 years ago
Summary: [y]Cookie Manager and Image Manager should be separate dialogs → Cookie Manager and Image Manager should be separate dialogs
Whiteboard: [y]
Netscape nav triage team: based on Steve Morse's pre-triage recommendation, this 
is not a beta stopper.
Keywords: nsbeta1-
(Assignee)

Updated

18 years ago
Whiteboard: [y]
(Assignee)

Updated

18 years ago
Target Milestone: --- → mozilla1.2
(Assignee)

Comment 9

18 years ago
There is currently a major reorg of all the cookie files going on in bug 46783.  
Part of that work will include the fix for this problem.  So when I check in the 
patches in that bug report I will mark this bug as fixed.
(Assignee)

Updated

18 years ago
Target Milestone: mozilla1.2 → mozilla0.9
(Assignee)

Comment 10

18 years ago
Fixed as part of the checkin for bug 46783 that just occured.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 11

18 years ago
verified 6/27 builds
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.