Gdk-CRITICAL error when trying to enter password in HTTP authentication dialog box

VERIFIED DUPLICATE of bug 27784

Status

()

Core
Event Handling
P3
major
VERIFIED DUPLICATE of bug 27784
18 years ago
18 years ago

People

(Reporter: Thomas Morin, Assigned: joki (gone))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
When I go on a page that requires HTTP authentication (HTTP basic
authentication, no SSL), the login/passwd dialog pops up, and after having
entered my login (and even if i don't enter it) whether if I click the passwd
text area (I mean the place where I have to type it, whatever it's real gtk name
is) or if I hit <TAB>, nothing appends in the GUI, and in the terminal I get
some 4 Gdk-CRITICAL Errors :

dk-CRITICAL **: file gdkwindow.c: line 1707 (gdk_window_get_parent): assertion
`window != NULL' failed.

(4 times)

It's a major bug in so far as it prevents from accessing *any* page requiring
HTTP Authentication.


Here is the complete dump of the output from the moment i hit enter after
entering the URL requiring authentication :

-----------------Entry at index 0 is ok
Entry at index 1 is http://ok/
WEBSHELL+ = 14
WEBSHELL+ = 15
WEBSHELL+ = 16
commonDialogOnLoad
setting info.header to
There are 2 buttons
setting password2.text to Password
setting login.text to User Name
WEBSHELL- = 15
WEBSHELL+ = 16
Move window by 0,20
screen x -1screen y -1
we have an event stuck -- removing it.
------------------------------------------------------------------
HERE I ENTER MY LOGIN THEN HIT TAB OR CLICK THE PASSWD TEXT AREA
------------------------------------------------------------------
Gdk-CRITICAL **: file gdkwindow.c: line 1707 (gdk_window_get_parent): assertion
`window != NULL' failed.

Gdk-CRITICAL **: file gdkwindow.c: line 1707 (gdk_window_get_parent): assertion
`window != NULL' failed.

Gdk-CRITICAL **: file gdkwindow.c: line 1707 (gdk_window_get_parent): assertion
`window != NULL' failed.

Gdk-CRITICAL **: file gdkwindow.c: line 1707 (gdk_window_get_parent): assertion
`window != NULL' failed.
---------------------------------

And then I got 4 more of these errors each time I click the passwd text area.
(I got 8 when i click it if it wasn't "selected" before)

Usefull info (i guess) :  libgtk/libgdk version: 1.2.7
Build ID : 2000051913  (but i've been seeing this bug from many weeks)

I hope i'm being useful, it's my first bug report.
I'm not sure having chosen the right component for this bug report.
Don't hesitate to tell me if i can improve my bug reporting way.
(Reporter)

Updated

18 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 1

18 years ago

*** This bug has been marked as a duplicate of 27784 ***

Comment 2

18 years ago
vrfy
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.