After updating Sunbird 0.2 to 0.7 and importing data restart is required to restore calendars

RESOLVED WONTFIX

Status

Calendar
General
RESOLVED WONTFIX
10 years ago
6 years ago

People

(Reporter: Omar Bajraszewski, Unassigned)

Tracking

Sunbird 0.2
x86
Windows XP

Details

(Reporter)

Description

10 years ago
After updating Sunbird 0.2 to 0.7 I noticed that the events became transparent in calendar view and found other issues.
Steps to reproduce:
1)Install Sunbird 0.2 and set your preferences i.e. set 'store dates in Universal Time'
2)Set 'play sound'
3)Set default alarm for events and tasks on (60 minutes before)
4)Set first day to monday
5)Timezone: Europe/Warsaw
6)Create 2 more local calendars
7)Create one simple event and task in default calendar ('My calendar') for today
8)Set a colour for second calendar and import USHolidays.ics
9)Set a colour for third calendar and import UKHolidays.ics
10)Quit Sunbird
11)Upgrade to 0.7
12)Start Sunbird and import data

Result:
1)Events are transparent
2)After update Day View became a default view
3)Timezone settings are lost (you have to set it again)
4)3 calendars disappeared and a new was created.

And now restart sunbird (I set a colour for new calendar before but I'm not sure if it's required for reproducing the problem).
Result:
5)You can see 4 calendars!

Comment 1

10 years ago
I could imagine that this is caused by the changed handling of the way calendars are added to the composite calendar / calendar list. Maybe the migration wizard was forgotten to update.

Comment 2

10 years ago
Issue still exists updating from Sunbird 0.5 to Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.13pre) Gecko/20080225 Calendar/0.8pre.

(After the update just one application restart is required to fix all issues.)
These versions are old enough for us not to care. If this still happens with later versions of Lightning (or Sunbird) please reopen
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.