your auto update of firefox erased all saved passwords

RESOLVED WORKSFORME

Status

()

Toolkit
Password Manager
--
critical
RESOLVED WORKSFORME
10 years ago
9 years ago

People

(Reporter: Joe Demalderis, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.8) Gecko/20071008 Firefox/2.0.0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.8) Gecko/20071008 Firefox/2.0.0.8

When you auto updated my Firefox all of my saved passwords were lost/erased.  This is a huge problem as it causes me considerable downtime in trying to recover all of the passwords.  These are passwords that are used routinely in operating my business.  Unfortunately, I will have to advise all my associates and others to longer use Firefox since the may encounter the same problem and the loss of income and additional business expense that I have. 

Reproducible: Always

Steps to Reproduce:
1.download an update from Firefox
2.
3.
Actual Results:  
lose all of your saved paswords

Expected Results:  
Expect a huge financial loss

Not lost the passwords
And you never made backups of your personal data? All software can corrupt or fail so this is always advisable.
Type %appdata% in your run box, in the window that is shown to you, search for the Mozilla folder, drag it a few centimeters away, choose Copy.
If you can't add new passwords anymore, search in your profile for the files signons2.txt and key3.db and delete them. 
http://kb.mozillazine.org/Signons.txt
http://kb.mozillazine.org/Profile_backup 

Not sure what happened here. The password manager code didn't change in this time frame, nor have I seen other bugs filed about similar issues. I can only assume this was some kind of isolated incident.

There's not really any thing to debug with here, so marking as WORKSFORME.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.