java plugin (jre1.6.0_u03) is installed but not recognized, firefox says additional plugins are required.

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
11 years ago
11 years ago

People

(Reporter: robert_solin, Unassigned)

Tracking

({qawanted})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.8) Gecko/20071008 Firefox/2.0.0.8
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.8) Gecko/20071008 Firefox/2.0.0.8

The example site above, and others that require java to display the page correctly
do not display correctly. The browser tool bar says "additional plugins are
required to display all the media on this page." Various boxes on the page e.g.
the upper left corner, which should display moving menus or advertisements instead
say "click here to download plugin." Clicking here takes you to the sun java site
and invites you to install the latest jre1.6.0_xx.  The problem is that firefox
does not understand that the plugin is installed and working. It does not see
it and will not use it.
The plugin is installed correctly because the sun java site test says it is and
because the plugin works perfectly well with other browsers e.g. opera and also
firefox 1.5.0.7 which I still have on the computer. I have never had a problem
with the plugin working with firefox 1.5 but have never had it work with
firefox 2.0.
Other details: I am using the kde3.5 desktop with slackware 11.0 (2.6.17 kernel.


Reproducible: Always

Steps to Reproduce:
1.turn on browser and make sure enable java is checked in the preferences
2.go to the above referenced web site and observe.
3.
Actual Results:  
web page is displayed but incorrectly. Several boxes are empty except for the 
words "click here to download plugin.

Expected Results:  
The empty boxes would normally have moving menus or other moving things in 
them. There should be no messages about additional plugins.

I have updated java several times and updated the os several times but have not
had the problem occur with firefox 1.5. It was only when I upgraded to firefox 2.0
that the problem occured.
I tend to do basic things with the browser, no special themes and usually only
one window or tab open.
"I have never had a problem with the plugin working with firefox 1.5 but have never had it work with firefox 2.0."

Have you tried other Firefox 2.0.0.x versions, or is 2.0.0.8 the first you've tried? I ask because Vista users are claiming we broke something in the upgrade to 2.0.0.8 (bug 400467). If you had problems in prior 2.0 versions then it's a separate problem. I suspect it is but it's good to be sure.

I know people run Java with Firefox 2.0.0.x on Linux, it might help to check out our tech support (web forums or IRC chat) to see if they can help you investigate what's going on. http://www.mozilla.com/support/
Keywords: qawanted
(Reporter)

Comment 2

11 years ago
Reply to comment #1: 

I have tried firefox 2.0.0.7 and one other 2.0 version and had the same problem.
Here is some more information on the problem. If I enable java script but
disable java in the preferences now all plugin warnings are gone and everything
on the page desplays correctly except for the menu in the upper left corner
under "hot topics". There should be a moving menu of articles under the date
but there isn't. It is strange that turning off java makes the page better and
turning on java makes it worse.

I think I have seen this problem mentioned somewhere but without a solution.

I know another site that works strangely with firefox 2.0.0.8, more about that
later.

Comment 3

11 years ago
Hello Robert,

one might also consider the root of the problem to be found in slackware. Debian testing f.e. has no problems with SUN's java and firefox 2.0.0.11. Hope this may help you.
(Reporter)

Comment 4

11 years ago
(In reply to comment #3)
> Hello Robert,
> 
> one might also consider the root of the problem to be found in slackware.
> Debian testing f.e. has no problems with SUN's java and firefox 2.0.0.11. Hope
> this may help you.
> 

Hello flibby or anyone else who is interested,

I have fixed the problem by adding a symbolic link to the java plugin in
my .mozilla/plugins directory.  This seems to be a change from the way 
firefox 1.5 worked which is why i didn't think of it before.  I still have
firefox 1.5.0.7 installed in another user account on the same machine and
it works perfectly. I examined all the plugins directories (both local and
system)  and none of them had any link to the java plugin. But firefox 1.5.0.7
was smart enough to find the java plugin in the usual place  (which is
 /usr/lib/jre1.6.0_03/plugin/i386/ns7/libjavaplugin_oji.so on my machine ).
Apparently firefox2.0 is no longer smart enough to find the java plugin in
the usual places. This is ok i guess but i found nothing about it in the 
linux install instructions or anywhere on the firefox site.
I assume that windows users don't have to worry about this since all they
have to do is push a button and someone has made sure it will work, but
when you are installing from a tar ball this is very important information
and should have been mentioned in the instructions.  I don't know if there is
a problem for people using rpms since i never use them.  I think the people 
who maintain slackware were also fooled by this since there was never a problem
with previous versions which had the firefox1.5 series.

I have heard from people with other distributions who had the same problem.
I hope this may help them.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.