where are the back and forward buttons???????

RESOLVED INVALID

Status

SeaMonkey
UI Design
RESOLVED INVALID
11 years ago
10 years ago

People

(Reporter: roger k meanor, Unassigned)

Tracking

SeaMonkey 1.1 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.8) Gecko/20071009 SeaMonkey/1.1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.8) Gecko/20071009 SeaMonkey/1.1.5

when i go to a link from on on my homepage, the [green] back button and also the [green] forward button disappear.  this was in the version before but figured it would be fixed.  so WHERE OH WHERE ARE MY FORWARD AND BACK BUTTONS.  they are "grayed out".   how do i fix this?   please email me with possible solutions.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

11 years ago
1. If we don't know about bugs, we can't fix them.
2. You didn't provide a link to your homepage, so we can't reproduce the problem...
3. You didn't specify which theme you are using - the default theme? Modern? A custom one? 
(Reporter)

Comment 2

11 years ago
ok, plain and simple - the back and forward green arrow buttons are inoperative.  the show up on the menu selection but are what is called 'greyed' out.  THEY DON'T WORK.  YOU CANNOT SELECT THEM. THEY ARE INOP. i don't know how to say it more simply.  they are there but they are not, meaning i cannot select them on any page, url or anywhere else. for example, when i first tried my password for the log in i got an error msg.  is said to press the back button.  back/forward button is on the menu bar, but isn't operative.  cannot select it, is not highlighted. "GREYED OR GRAYED" OUT.  doesn't work.  sorry to sound so argumentative,  but i had this before.  reinstalled seamonkey multiple times and would get is back for awhile, time indeterminate, then would quit working, and button arrows not highlighted.  that's it.  don't know what else to say.   roger

Comment 3

11 years ago
To diagnose the problem people need to know how to reproduce it - only by recreating it can they understand what goes wrong, and potentially see how to fix it.

That's why it is important to describe what you did to make the problem come about can help. Knowing what you are actually using (i.e. which user interface theme you are using), is also important. If you don't provide this type of information no one can or will help you. 
(Reporter)

Comment 4

11 years ago
take the standard download.  only thing i do is put it in a separate folder instead of window program file on the c: drive.  the theme is the standard.  there are no changes to the program except to set up where the download folder is located.  it is pretty much a stock install.  i don't know what else to tell you. the missing buttons are missing from the menu after the install is completed and run for the first time after the setup.  if there is something u would like me to do to get info for you, let me know and i will make an attempt to do so. i am at a lose to do so.  the buttons are there for firefox, for netscape9.0.  i wish i could give u more, but that is all i have.  is there a setting in the config that could be improperly set?   roger

Comment 5

11 years ago
Thanks. That is very helpful. 

Ok, I just downloaded Seamonkey 1.1.5 (ZIP file version) and installed it in a no-standard folder. I then browsed around for several minutes, and could not reproduce the problem. Which is good for Seamonkey, of course, but admittedly not so useful for you :-( 

Did you download the ZIP version, or the self extracting installer?  

If you used the installer, you could try uninstalling seamonkey (and previous versions) and then reinstalling 1.1.5, and see if that helps.

If that doesn't work, maybe it's something about your personal settings. To test this you could create a brand new user account on your XP machine, login as the new user, and run seamonkey from there. If it works properly under the new account, and not your current one, then the problem likely lies in your personal settings files.
(Reporter)

Comment 6

11 years ago
unzipped zip version to folder, ran same, same problem,missing back/forward buttons.  removed installed ver. removed all folders of it on drive.  did a reboot, ran from unzipped folder,  same problem.   made a new account.  ran seam. from unzipped folder.  same problem remained.  no buttons.  is there some setting that i am missing somewhere.  have firefox, netscape9.0,thunderbird and opera, along with ie [which hardly use].  in the c: drive, the path is documents and settings, user[me],application data,mozilla, then the folders firefox, profiles, sunbird.  the firefox and profiles look to be practically identical. i have no idea where to look.  did an upgrade to firefox, netscape, opera and to seamonkey, then did as u mentioned and did a removal and clean install. running out of ideas. do u have any where for me to look for this.   using classic theme, made no changes.   where is the seamonkey info,  is it in the apps data folder, mozilla or elsewhere? cannot find the listing of seamonkey anywhere. or is it in the folder that i have seamonkey installed/unzipped to.  also is there going to the right mouse click availability to customize the menus. miss that, it is in firefox and netscape, where is it in seamonkey.  use seamonkey as it  is integrated with the email and can do what i want from one pgm.  what do u think i need to do??  i am completely out of ideas where to look. could there be a setting the the configuration type pgms that have somehow changed?  where would i look in xp for any changes?   roger

Comment 7

11 years ago
Mozilla puts generic stuff in C:\program files\... (or wherever you unpacked it), but creates personal user settings in:

C:\Documents and Settings\<user name>\Application Data\Mozilla\

Where <user name> is your user name. The Application Data folder may be invisible -- it's a system file. Note also, though, that Firefox stuff might be in:

C:\Documents and Settings\<user name>\Application Data\Mozilla\Firefox\, and you don't want to delete that.

So one option is to go to the ..\Application Data\MOzilla\ folder and move everything except the Firefox folder to another location, and then restart Seamonkey and see what happens. 

(Reporter)

Comment 8

11 years ago
tried all the suggestion that ian graham mentioned.  finally i made a new account, unzipped the seamonkey zip program.  installed it on the newly created account,  this was mainly all that was on this account.  when i went ahead and ran the program, the same error[bug] was there.  the back and forward arrow buttons are still 'greyed' out.  in other words,  they don't work as advertised. really, i have no idea what is wrong or how to cure it.  my thanks to ian for all his assistance, but he is baffled about it too.   can anyone out there help.  can there be a pgm that i have running or an extension or whatever that is causing this.  this error does not occur in firefox or netscape 9.001.  any ideas and brainstorming would be appreciated.  oh, thanks ian for all your help.  wish that we could have solved this.       
(Reporter)

Comment 9

11 years ago
little more input in what i see.
on homepage or any first url selection;
select a link or news item on page.
--see the url for the selection appear on the status bar, however, when gone to the selection, the home page url in in the window and not the selected url.  
--so, pgm cannot see that it has been changed by parsing the address window and no back/forward buttons.  doesn't seem to effect pgm if you are on the third+ tab or window.   
Does this help.

Updated

11 years ago
Assignee: general → guifeatures
Component: General → XP Apps: GUI Features
QA Contact: general
Version: unspecified → 1.8 Branch

Comment 10

10 years ago
I also have the problem with missing forwards/back button, but I assumed it was a problem with coexistence of 3.0b5 and 2.0.x - sometimes (perhaps after a crash?) 2.0.x would start up when I was expecting 3.0b5.

I tried to install a skin to fix it, but this didn't work.
Roger,
Can you reproduce with SeaMonkey v1.1.9 ?

danskal,
Please "file" a separate report for Firefox.
Version: 1.8 Branch → SeaMonkey 1.1 Branch
Filter "spam" on "guifeatures-nobody-20080610".
Assignee: guifeatures → nobody
QA Contact: guifeatures

Comment 13

10 years ago
Quote from Comment #4 "the missing buttons are missing from the menu after the install is completed and run for the first time after the setup."

This is the critical clue. When you first start Firefox. You have been to no other page, before seeing this page, and you have not gone to another page, and returned to that page. 

If you had, you would notice functional Back and Foreward buttons. If the page is the first page seen, and you haven't gone to another page and used the back button to get back to it, both buttons will be grayed out because you have nothing to go back to and nothing to go forward to.

Updated

10 years ago
Component: XP Apps: GUI Features → UI Design
Thanks Ellen, I really think that that is what the reporter meant.

Resolving.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.