Seamonkey 1.1.5 declared incompatible, Firefox suggested, Navigator 9 accepted.

VERIFIED DUPLICATE of bug 401709

Status

SeaMonkey
General
VERIFIED DUPLICATE of bug 401709
10 years ago
10 years ago

People

(Reporter: Rich, Unassigned)

Tracking

SeaMonkey 1.1 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.8) Gecko/20071009 SeaMonkey/1.1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.8) Gecko/20071009 SeaMonkey/1.1.5

Server identifies Seamonkey 1.1.5 as an incompatible browser. Navigator 9 is accepted. I don't understand this. Is 1.1.5 reporting itself differently to 1.1.4?

Reproducible: Always

Steps to Reproduce:
1.Launch Seamonkey 1.1.5
2. Visit www.comcast.net
3. Be told Seamonkey is incompatible
Actual Results:  
As above

Expected Results:  
Site should accept Seamonkey as a valid browser.

I don't see why Navigator 9.0 should be accepted and Seamonkey 1.1.5 be rejected.
(Reporter)

Updated

10 years ago
Version: unspecified → SeaMonkey 1.1 Branch

Comment 1

10 years ago
> Is 1.1.5 reporting itself differently to 1.1.4?

Do you mean it worked with 1.1.4? And yes, 1.1.5 sends a different User-Agent. But it's stupid anyway to block users based on their User-Agent and/or browser they use. It uses the same rendering engine as Firefox (and Navigator 9.0 uses also the same engine called Gecko).
To Rich(bug opener):

See Bug 80658 and Bug 386113 which can be easily found by very simple advanced search of "Product=Moz AppSuite, status=---(open), summary contains 'User AND Agent', updated within 3 months.
See also Bug 387416 which is pointed by Bug 386113 Comment #29.

By the way, here is mozilla.mozilla.org, not support forum nor help center.
If you need someone's help or answer to your question, ask at support forum such as MozillaZine forums first, please.
If you are reporting site problem, open bug with proper Product, Product=Tech Evangelism.
(Reporter)

Comment 3

10 years ago
I am aware this is not a support forum. I did do a search using "comcast.net" as a search string. I am not to know it was called something else.

Anyway, here is my response to the first comment:

"I know comcast.net recently rolled out anew website, so chances are 1.1.4 would be also declared incompatible. Is there a way to config the app to report it is IE7, or Navigator 9.0 or Firefox 2.0?"

Please don't think I am a noob at this stuff. I have been using web browser software since Netscape 2.0. Thank you for your consideration.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 401709

Updated

10 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.