middle-clicking on a link to open up a tab opens up 2 of the same tabs

RESOLVED WORKSFORME

Status

()

Firefox
Tabbed Browser
--
major
RESOLVED WORKSFORME
11 years ago
9 years ago

People

(Reporter: john nelson, Unassigned)

Tracking

2.0 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2009-08-25])

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.6) Gecko/20071008 Ubuntu/7.10 (gutsy) Firefox/2.0.0.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.6) Gecko/20071008 Ubuntu/7.10 (gutsy) Firefox/2.0.0.6

WHen i middle click to open a new tab it opens a 2 of the same tabs. When i middle click on one of the 2 tabs that are opened it closes those 2 tabs and a couple other opened tabs.

Reproducible: Sometimes

Steps to Reproduce:
1.
2.
3.


Expected Results:  
the software should have opened one new tab not 2 additional tabs.

Pentium 3 933Mhz
512mb ram
815e chipset
160GB hdd   
ext3 file system
Have you tried:

- Firefox's safe-mode to exclude extension/theme problems
- a new profile
- a reinstall in a new empty folder? 

http://kb.mozillazine.org/Safe_Mode_(Firefox)
http://kb.mozillazine.org/Profile_Folder
(Reporter)

Comment 2

11 years ago
same thing happens.
WFM with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.8) Gecko/20071008 Firefox/2.0.0.8
Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9a9pre) Gecko/2007110705 Minefield/3.0a9pre - Build ID: 2007110705

I am also seeing the opening twice issue sometimes (since yesterday). Will try to reproduce the close error next time.
Ok, I still have the problem of tabs opening twice, but have never seen both closing at the same time.
Summary: middle clicking on a link to open up a tab opens up 2 of the same tabs → middle-clicking on a link to open up a tab opens up 2 of the same tabs
I have seen now also the closing problem occurring randomly, maybe these are two different bugs.

Adding 'qawanted'
Keywords: qawanted

Comment 7

11 years ago
I've tried to reproduce this bug succesfully!
Before I didn't understand why sometimes it happend and sometimes not.
Now I can reproduce it!

Try it:
middle-click a link... but don't release the mouse-middle-wheel, instead let it roll a bit... and bang ! two new tabs show up!

My mouse wheel is old, so it does roll very easily inadvertedly, thus when I click  on it I often roll it too.

feel free to ask me questions, if you need other infos.

So in my opinion this bug it's an incorrect managemement of the mouse middle wheel rotation during a click on it with the mouse cursor on a link.

I confirm that sometimes trying to close one of the two twin tabs, firefox closes them both.. and after a few of those strange behaviours it slows down or hangs.

This bug has been introduced, as far as I'm concerned , between 2.0.0.10 and 2.0.0.11, and still is active on 2.0.0.12 



 

Comment 8

11 years ago
I made some other tests...!
In firefox-safe mode, with firefox 2.0.0.12,  under windows xp sp2 ITALIAN, 

I clicked on the google home page links, with the middle mouse wheel/button, while rolling it fast, and firefox opened from 2 to 3 identical tabs!

Now that I know why, I pay much attention to my middle-clicks, and avoid rotation,  so resulting in less or no twin tabs opening by firefox.

Comment 9

10 years ago
Here's a video showing the bug in action, in Firefox 2.0.0.13, under winxp sp2 pro.

http://www.youtube.com/watch?v=RNvdSpeypQw

good bug-hunting!

Comment 10

10 years ago
In Firefox 3.0.1 in ArchLinux the same problem occurs.
It does not seem to be so easily induced by scrolling while clicking,
and my mouse isn't the best, but it is still pretty good.
Perhaps it is Firefox perhaps it is the mouse,
nonetheless the problem occurs, both in opening and closing tabs.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008061913 Firefox/3.0

Comment 11

10 years ago
Still confirmed under 
Mozilla/5.0 (Windows; U; Windows NT 5.1; it; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3

Now that I know, it's  very easy to reproduce this bug!
I made a video to show the bug. I'll upload here as attachment is asked.

2.5 megabytes, avi file.

Comment 12

10 years ago
I'm starting to suspect that this is a mouse problem and not a software problem. It is quite frustrating, but I totally took apart my mouse and put it back together again and haven't experienced the problem since then really. It seems to come and go, and I think I'm going to blame the mouse now.

Perhaps it is a software problem, but the mouse seems to be more of a culprit (because it's happened in other programs too).
Does anyone still see this problem with the latest Firefox 3.5.2 release? If can how do other applications behave? Could we blame the mouse driver? What happens if you connect another mouse to your box?
OS: Linux → All
Hardware: x86 → All
Whiteboard: [closeme 2009-08-25]
Version: unspecified → 2.0 Branch
WFM with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.4pre) Gecko/20090831 Shiretoko/3.5.4pre ID:20090831030742
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Keywords: qawanted
Resolution: --- → WORKSFORME

Comment 15

9 years ago
Sorry, I don't agree with the decision of setting this bug in solved status.
I still can reproduce this bug.

Position the pointer over a hyperlink.
then just rotate fast the middle wheel of your mouse while clicking.
Done... in my firefox two or more new tabs pop up!

I admit this happens less then in the past, yet it still happens.

I'm now using firefox 3.5.3 on a windows vista X64 platform.

Mozilla/5.0 (Windows; U; Windows NT 6.0; it; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)
Roberto, while reading your comment 7 I get the impression that your mouse is firing mouseup events when you scroll. That will cause Firefox to open a new tab for each of those events. Please also check with another mouse. I think it will work. How do other applications react on the given steps?

Comment 17

9 years ago
I tested this "bug" over Internet explorer 8... and its behavior it's right the same: more than one tab pops up.

Therefore it's not just or only a firefox "bug".
in the past I suffered for this bug much more than now, I think it depends on a timing setting in responding to the mouse events.

Internet explorer is, nonetheless , a bit less prone to showing that multiple tabs misbehavior.
I think IE8 has just a longer time threshold between two sequential clicks (or events) from the mouse buttons.

Is it possible to increase this parameter (the minimum time threshold between to sequential middle mouse clicks )in firefox?
it could resolve the bug in firefox, and leave this uncomfortable behavior to ie8 ;-)

I wish this information helps.
roberto
Neil, what do you think?
You need to log in before you can comment on or make changes to this bug.