Static page titles are not localizable

VERIFIED FIXED in 4.0.3

Status

addons.mozilla.org Graveyard
Localization
--
minor
VERIFIED FIXED
10 years ago
2 years ago

People

(Reporter: George Fiotakis, Assigned: wenzel)

Tracking

unspecified
4.0.3

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; el-GR; rv:1.8.1.8) Gecko/20071008 Firefox/2.0.0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; el-GR; rv:1.8.1.8) Gecko/20071008 Firefox/2.0.0.8

Allthough there is a localized string for "Credits" in all languages (footer_credits string, messages.po file), AMO uses the english word for all valid and supported locales as a page title.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.


Expected Results:  
The page title should use the localized string instead.

Comment 1

10 years ago
This applies to all page views (that's appversions, credits, submissionhelp etc.) because as you can see in site/app/controllers/pages_controller.php:61 it uses a generic display function to set the title to the pagename with the first letter capitalized (so there's no localization at all).

site/app/controllers/pages_controller.php:86
$title = ucfirst($path[$count - 1]);

Maybe something like using the pagename as part of the msgid would be a good workaround (credits_pagetitle, appversions_pagetitle etc.)? Would have to update all of the po files too.
(Assignee)

Updated

10 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

10 years ago
Duplicate of this bug: 421181
(Assignee)

Updated

10 years ago
Severity: trivial → minor
Hardware: PC → All
Summary: The localized string for "Credits" is not displayed as the page title → Static page titles are not localizable
(Assignee)

Updated

9 years ago
Blocks: 462481
(Assignee)

Comment 3

9 years ago
I'll fix it for the 4.0.3 milestone. Will probably make a switch statement for the page title, defaulting to the current behavior.
Assignee: nobody → fwenzel
No longer blocks: 462481
Target Milestone: --- → 4.0.3
(Assignee)

Updated

9 years ago
Blocks: 462481
Status: NEW → ASSIGNED
(Assignee)

Comment 4

9 years ago
Created attachment 346289 [details] [diff] [review]
Possibility to localize page titles, incl. titles for the existing pages
Attachment #346289 - Flags: review?(clouserw)
Comment on attachment 346289 [details] [diff] [review]
Possibility to localize page titles, incl. titles for the existing pages

I'd rather have the title in the .thtml files somehow but I can't think of a clean way to do it.  Them's the breaks I guess.
Attachment #346289 - Flags: review?(clouserw) → review+
(Assignee)

Comment 6

9 years ago
Committed to r19531. l10n merged out to all locales in r19533.
Keywords: push-needed
(Assignee)

Updated

9 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Fred: ok to verify this as fixed since it was used to fix bug 462481, right?
(Assignee)

Comment 8

9 years ago
Yes, since that bug was verifiable, this one is fixed by definition too. :)
Thanks Fred; verified fixed.
Status: RESOLVED → VERIFIED
(Assignee)

Comment 10

9 years ago
Has been pushed live last night.
Keywords: push-needed
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.