Font size change in Prefs doesn't affect location bar until hide/unhide bar

VERIFIED DUPLICATE of bug 26077

Status

()

P3
major
VERIFIED DUPLICATE of bug 26077
19 years ago
14 years ago

People

(Reporter: nnbugzilla, Assigned: erik)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.73 [en] (Win98; U)
BuildID:    2000051908

Changing font size in Preferences to something smaller causes location bar font 
to be too large for location bar size.

Reproducible: Always
Steps to Reproduce:
1. Go into Preferences and change the font size from the default to something 
smaller, like 12 pt, then select OK


Actual Results:  Note font in location bar seems to be a bit too large now, so 
descenders and underscores aren't visible.  Hide the location bar and then 
unhide it, and the font is now the correct size;  that is, descenders and 
underscores are visible.

Expected Results:  Either location bar size should not change after changing 
font size in Prefs, or the location bar font should change at the same time as 
the actual bar.
(Reporter)

Comment 1

19 years ago
Upon further investigation, it looks like the font in the location bar is
actually increasing in size, while the location bar itself remains the same size.

Comment 2

19 years ago
One of two things needs to happen here: either the location bar font needs to be
fixed like other UI fonts (e.g. Personal Toolbar) or the location field needs to
grow with font size changes.

Reassigning to XP Toolkit/Widgets.
Assignee: bdonohoe → trudelle
Status: UNCONFIRMED → NEW
Component: User Interface: Design Feedback → XP Toolkit/Widgets
Ever confirmed: true
QA Contact: mpt → jrgm
(Reporter)

Comment 3

19 years ago
Perhaps this should be a DUPL of 26077, after all.

Comment 4

19 years ago
Doesn't sound like a dup of that bug, but in any case, this isn't ours. changing
component to editor, reassigning.
Assignee: trudelle → beppe
Component: XP Toolkit/Widgets → Editor
QA Contact: jrgm → sujay

Comment 5

19 years ago
I hate to keep passing this along -- but, I think maybe Erik should own this one
Assignee: beppe → erik
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → M18
(Reporter)

Comment 6

19 years ago
It's not an exact dup of 26077, after all, but very similar.  I've reduced it to 
the smallest number of steps now.  Simply going into Prefs and selecting OK 
right away doesn't do it.  Go into Prefs, select the Fonts panel, and then 
select OK without making any changes in the fonts, however, WILL do it.  
Moreover, doing it this way causes the location bar font to become quite large, 
and on my system, changes it from a sans serif to a serif font.

Comment 7

19 years ago
On a Linux 0524 build, if you just click the OK in the fonts pref, Mozilla uses
the font.default font in the font.size.variable size. If I use a sans-serif
default but make Courier the default sans-serif font, then Mozilla uses Courier
at my default of 14px.

It's as if it's ignoring chrome/locales/en-US/global/locale/intl.css.
Yeah, this is a dup of 26077 all right.


*** This bug has been marked as a duplicate of 26077 ***
Severity: normal → major
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
OS: Windows 98 → All
Hardware: PC → All
Resolution: --- → DUPLICATE

Comment 9

19 years ago
verified in 5/30 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.