Crash [@ _PR_MD_ATOMIC_INCREMENT] via nsNavHistoryContainerResultNode::GetSortingAnnotation

RESOLVED DUPLICATE of bug 387203

Status

()

Firefox
Bookmarks & History
--
critical
RESOLVED DUPLICATE of bug 387203
10 years ago
8 years ago

People

(Reporter: ted, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
I came back to my PC to find minefield crashed, but I attached a debugger and got this stacktrace:

>	nspr4.dll!_PR_MD_ATOMIC_INCREMENT(int * val=0x6569266b)  Line 711 C
 	xul.dll!nsACString_internal::Assign(const nsACString_internal & str={...})  Line 396 + 0xc bytes	C++
 	xul.dll!nsNavHistoryContainerResultNode::GetSortingAnnotation(nsACString_internal & aAnnotation={...})  Line 556	C++
 	xul.dll!nsNavHistoryFolderResultNode::FillChildren()  Line 2953	C++
 	xul.dll!nsNavHistoryFolderResultNode::OpenContainer()  Line 2776 C++
 	xul.dll!nsNavHistoryContainerResultNode::SetContainerOpen(int aContainerOpen=1)  Line 347	C++
 	xul.dll!NS_InvokeByIndex_P(nsISupports * that=0x60406f1c, unsigned int methodIndex=187180432, unsigned int paramCount=19, nsXPTCVariant * params=0x00000001)  Line 102	C++
 	xul.dll!AutoJSSuspendRequest::SuspendRequest()  Line 3318 + 0x9 bytes	C++
 	nspr4.dll!_MD_CURRENT_THREAD()  Line 300	C
 	nspr4.dll!_PR_MD_UNLOCK(_MDLock * lock=0x00d66ec1)  Line 347	C
 	js3250.dll!JS_GetScriptFilenameFlags(JSScript * script=0x0001ac70)  Line 1632 + 0x6 bytes	C
 	js3250.dll!JS_GetTopScriptFilenameFlags(JSContext * cx=0x60404ac3, JSStackFrame * fp=0x01381694)  Line 1620 + 0x8 bytes	C
 	ntdll.dll!_RtlFreeHeap@12()  + 0x130 bytes	
 	xul.dll!XPCWrappedNative::CallMethod(XPCCallContext & ccx={...}, XPCWrappedNative::CallMode mode=CALL_SETTER)  Line 2326 + 0x15 bytes	C++
 	xul.dll!XPC_WN_GetterSetter(JSContext * cx=0x0161e878, JSObject * obj=0x0f4d1840, unsigned int argc=1, long * argv=0x0b1088c8, long * vp=0x0012f350)  Line 1492	C++
 	js3250.dll!js_Invoke(JSContext * cx=0x00000001, unsigned int argc=1, long * vp=0x068e0c14, unsigned int flags=2)  Line 1382 + 0x11 bytes	C
 	js3250.dll!js_InternalInvoke(JSContext * cx=0x0161e878, JSObject * obj=0x0f4d1840, long fval=256710944, unsigned int flags=0, unsigned int argc=109972492, long * argv=0x0012f590, long * rval=0x0012f590)  Line 1458 + 0xf bytes	C
 	js3250.dll!js_InternalGetOrSet(JSContext * cx=0x0161e878, JSObject * obj=0x0f4d1840, long id=20453012, long fval=256710944, JSAccessMode mode=JSACC_WRITE, unsigned int argc=1, long * argv=0x0012f590, long * rval=0x0012f590)  Line 1523 + 0x17 bytes	C
 	js3250.dll!js_NativeSet(JSContext * cx=0x0161e878, JSObject * obj=0x0f4d1840, JSScopeProperty * sprop=0xffffffff, long * vp=0x0012f590)  Line 3569 + 0x27 bytes	C
 	js3250.dll!js_SetProperty(JSContext * cx=0x0161e878, JSObject * obj=0x0f4d1840, long id=20453012, long * vp=0x0012f590)  Line 3828 + 0xd bytes	C
 	js3250.dll!js_Interpret(JSContext * cx=0x0161e878, unsigned char * pc=0x00dde3ae, long * result=0x0012f5d8)  Line 3846	C
 	js3250.dll!SendToGenerator(JSContext * cx=0x00000000, JSGeneratorOp op=JSGENOP_SEND, JSObject * obj=0x0f4d15c0, JSGenerator * gen=0x00000000, long arg=0, long * rval=0x0a414214)  Line 889	C
 	js3250.dll!generator_op(JSContext * cx=0x0161e878, JSGeneratorOp op=JSGENOP_SEND, long * vp=0x00000000)  Line 1006 + 0x11 bytes	C
 	js3250.dll!generator_send(JSContext * cx=0x0161e878, unsigned int argc=1, long * vp=0x0a414214)  Line 1014 + 0xf bytes	C
 	js3250.dll!js_Interpret(JSContext * cx=0x0161e878, unsigned char * pc=0x00de0258, long * result=0x0012f7b8)  Line 4082 + 0xf bytes	C
 	js3250.dll!js_Invoke(JSContext * cx=0x00000001, unsigned int argc=1, long * vp=0x0a4140dc, unsigned int flags=2)  Line 1402 + 0xf bytes	C
 	js3250.dll!fun_apply(JSContext * cx=0x0161e878, unsigned int argc=1, long * vp=0x0a4140c4)  Line 1730	C
 	js3250.dll!js_Interpret(JSContext * cx=0x0161e878, unsigned char * pc=0x00de0f78, long * result=0x0012f9c4)  Line 4082 + 0xf bytes	C
 	js3250.dll!js_Invoke(JSContext * cx=0x00000001, unsigned int argc=1, long * vp=0x0a414020, unsigned int flags=2)  Line 1402 + 0xf bytes	C
 	xul.dll!nsXPCWrappedJSClass::CallMethod(nsXPCWrappedJS * wrapper=0x0687b338, unsigned short methodIndex=3, const XPTMethodDescriptor * info=0x00cfeab8, nsXPTCMiniVariant * nativeParams=0x0012fb88)  Line 1443 + 0x12 bytes	C++
 	xul.dll!nsXPCWrappedJS::CallMethod(unsigned short methodIndex=3, const XPTMethodDescriptor * info=0x00cfeab8, nsXPTCMiniVariant * params=0x0012fb88)  Line 566	C++
 	xul.dll!PrepareAndDispatch(nsXPTCStubBase * self=0x0379e828, unsigned int methodIndex=3, unsigned int * args=0x0012fc40, unsigned int * stackBytesToPop=0x0012fc30)  Line 114 + 0x15 bytes	C++
 	xul.dll!SharedStub()  Line 142	C++
 	xul.dll!nsTimerImpl::Fire()  Line 407	C++
 	xul.dll!nsTimerEvent::Run()  Line 459	C++
 	xul.dll!nsThread::ProcessNextEvent(int mayWait=36145912, int * result=0x02278af8)  Line 491	C++
 	xul.dll!nsTimerImpl::Fire()  Line 407	C++
 	xul.dll!nsThread::ProcessNextEvent(int mayWait=1, int * result=0x0012fc88)  Line 491	C++
 	xul.dll!NS_ProcessNextEvent_P(nsIThread * thread=0x00000001, int mayWait=1)  Line 227 + 0xd bytes	C++
 	xul.dll!nsBaseAppShell::Run()  Line 154 + 0x8 bytes	C++
 	xul.dll!nsAppStartup::Run()  Line 171	C++
 	xul.dll!XRE_main(int argc=1, char * * argv=0x00337ad0, const nsXREAppData * aAppData=0x00337e08)  Line 3144	C++
 	firefox.exe!main(int argc=1, char * * argv=0x00337ad0)  Line 154	C++
 	firefox.exe!WinMain(HINSTANCE__ * __formal=0x00400000, HINSTANCE__ * __formal=0x00400000, char * args=0x00152329, HINSTANCE__ * __formal=0x00400000)  Line 166 + 0x13 bytes	C++
 	firefox.exe!__tmainCRTStartup()  Line 589 + 0x1d bytes	C
 	kernel32.dll!_BaseProcessStart@4()  + 0x23 bytes

FWIW, I have Synchotron installed.
(Reporter)

Updated

10 years ago
Severity: normal → critical
ted, which build of minefield are you running?

I'm hoping it was a build before the fix for bug #387203 went in, and this is just a dup.
(Reporter)

Comment 2

10 years ago
Oh yeah, looks like I'm a few days behind:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a9pre) Gecko/2007101805 Minefield/3.0a9pre

Such a hassle to search dupes.  :-/
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 387203
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.