today-pane: events with too early end-time not shown

RESOLVED WORKSFORME

Status

Calendar
Lightning Only
--
major
RESOLVED WORKSFORME
11 years ago
10 years ago

People

(Reporter: Michael Arnold, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.1.6) Gecko/20071008 Ubuntu/7.10 (gutsy) Firefox/2.0.0.6
Build Identifier: 

Lightning 0.7 RC2 with TB 2.0.0.6

If an event in the future has an end time which is before the time when Thunderbird started (only the time, not the date), it is not shown in the today-pane in the mail-view of Thunderbird if you select the day of the event.

Reproducible: Always

Steps to Reproduce:
1. I start TB, let's say on Oct 22, 8:17 PM
2. I create an event that ends on Oct 23, 8:17 PM
3. I switch to the e-mail view and look at the today-pane. "Tomorrow" shows the new event.
4. Now I jump one day forward in the today-pane. The event disappears (it shouldn't).
5. I edit the event so that it ends on Oct 23, 8:18 PM.
6. Now, it's shown in the today-pane even if Oct 23 is selected.

Actual Results:  
The event is not shown if the end time is too early (i.e. has a time prior to the time that Thunderbird has started).

Expected Results:  
The event should be shown because it has a date in the future.

Comment 1

11 years ago
For reference, Berend mentioned this problem in bug 389854 comment 2 and bug 394054 comment 2.

Comment 2

11 years ago
True, but Berend's comments intend to track the current time of day, and show events on (Date == Today) where their end times are after the current time.  This bug captures the fact that currently, events on (Date == Today) and (Date != Today) show up only if their end times are after the launch time of Thunderbird.  This is unintuitive at best, and wrong at worst -- for dates in future, clearly the events should be shown; for dates in the past, I doubt the user intends to see nothing ("Sorry -- nothing in the past is still unfinished, so your schedule in the past is empty!"); so the behavior for Today is the only special case.  Perhaps showing completed events as grayed out (whether today or in the past) and uncompleted events (today or in the future) in full black color would be a better UI choice, since it doesn't conceal information.  If not, this choice should be exposed as a preference somewhere, since clearly people have differing opinions on how it should work :)
Works for me using Lightning 0.8pre (2008022020) + Thunderbird 2.0.0.13pre (20080219) on Windows XP.

Ben, could you retest with a recent Lightning 0.8pre nightly build?

Comment 4

10 years ago
Works for me, using Lightning nightly from 2/19/08 -- events show up regardless of what time TB is launched.  I still think it's odd behavior for events to disappear once completed (e.g. for a meeting from 9:30-10:30 to disappear from the today pane at 10:31) and would prefer them to appear grayed out, as I mentioned above.  But that's a separate issue discussed already in bug 394054, so I won't harp on it further here.
Resolving as WORKSFORME per Comment #3 and Comment #4.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.