ctrl + d ("bookmark this page") gave me the edit dialog in a broken state

RESOLVED DUPLICATE of bug 395813

Status

()

Firefox
Bookmarks & History
RESOLVED DUPLICATE of bug 395813
11 years ago
9 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

ctrl + d ("bookmark this page") gave me the edit dialog in a broken state

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a9pre) Gecko/2007102005 Minefield/3.0a9pre

I have not been able to reproduce this.

from my console:

Error: uncaught exception: [Exception... "Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsINavBookmarksService.getItemTitle]"  nsresult: "0x80070057 (NS_ERROR_ILLEGAL_VALUE)"  location: "JS frame :: chrome://browser/content/places/editBookmarkOverlay.js :: EIO__getItemStaticTitle :: line 297"  data: no]

I think that means that _itemId was bogus, possibly -1.

293   _getItemStaticTitle: function EIO__getItemStaticTitle() {
294     const annos = PlacesUtils.annotations;
295     if (annos.itemHasAnnotation(this._itemId, STATIC_TITLE_ANNO))
296       return annos.getItemAnnotation(this._itemId, STATIC_TITLE_ANNO);
297     return PlacesUtils.bookmarks.getItemTitle(this._itemId);
298   },
by "broken state", I mean all the the ui elements of the edit dialog popup where shown.
> I have not been able to reproduce this.

still no luck.

I'll keep an eye out for it, and keep this bug open in case someone else hits it.
(In reply to comment #1)
> by "broken state", I mean all the the ui elements of the edit dialog popup
> where shown.
> 

I've seen this too, with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a9pre) Gecko/2007101810 Minefield/3.0a9pre .  When opened, everything was shown, and one or both of the expanders didn't work.  Opening and closing a couple times made it start working normally again.

Was able to make it happen.  Screenshot shows how it came up.  Started the browser, one tab only, containing an image from a chrome URL.  Starred it, clicked the star button a couple times (I think the dialog came up normally), then the edit dialog popped up showing too many fields.  The upper expander, when clicked, changed state, but didn't change which fields were shown.  The lower expander worked and opened the tags list.  Closed the dialog. Clicked the star button, and the dialog opened showing everything, including now the tags list.

I saved out the Error Console contents if anyone wants it.

Again with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a9pre) Gecko/2007101810 Minefield/3.0a9pre .
Created attachment 285872 [details]
screenshot of places edit dialog with too many fields
this bug is sounding a lot like bug #395813

Comment 7

11 years ago
Yeah sounds the same.

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 395813
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.