download manager ignores user specified file handling

NEW
Unassigned

Status

()

Toolkit
Downloads API
11 years ago
7 years ago

People

(Reporter: timeless, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a9pre) Gecko/2007101304 Minefield/3.0a9pre

steps:
1. install Microsoft Office PowerPoint 2003
2. install Microsoft Office PowerPoint Viewer 2007 <http://www.microsoft.com/downloads/details.aspx?familyid=048dc840-14e1-467d-8dca-19d2a8fd7485&displaylang=en>
3. load the url for this bug (or any valid PowerPoint file if you really prefer such a thing)
3' dialog:
Opening data:application/vnd.ms-powerpoint,.pptfoo
You have chosen to open
 [) data:application/vnd.ms-powerpoint,.pptfoo
    which is a: Microsoft PowerPoint Presentation
    from: data:

 What should Minefield do with this file?
   (*) Open with [Microsof Office PowerPoint ...|v]
   ( ) Save File

   [ ] Do this automatically for files like this from now on.

                                          [      OK     ] [    Cancel    ]
4. Select
(*) Open with [Other...]
5. Browse to the viewer, typically:
"C:\Program Files\Microsoft Office\Office12\PPTVIEW.EXE"
5'
   (*) Open with [PPTVIEW.EXE                   |v]

6. Select
   [x] Do this automatically for files like this from now on.
7. OK
7' dialog:
Microsoft Office PowerPoint Viewer 
/!\ PowerPoint Viewer cannot open the file "ie5FoF59.ppt.part.ppt" because he file is not a PowerPoint file.
                    [ OK ]
8. OK
9. Tools>Downloads
10. Double click the most recent entry in completed
10' Power Point opens with
.pptfoo in the title field of a slide.
(Reporter)

Comment 1

11 years ago
Expected results:
'always' should include the download manager window....
Resolving old UNCONFIRMED Download Manager bugs as INCOMPLETE.  If you still see this issue, please reopen.

To mark all these bug changes as read, filter on ONOMATOPOEIA.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 3

10 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008032705 Minefield/3.0pre
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---

Updated

10 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.