Google Desktop shows up in list of extensions and cannot be uninstalled

RESOLVED INVALID

Status

()

Toolkit
Add-ons Manager
RESOLVED INVALID
11 years ago
9 years ago

People

(Reporter: marcia, Unassigned)

Tracking

Trunk
All
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 285933 [details]
Screenshot of Google Desktop in Addons

Seen using Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.8pre) Gecko/2007102306 BonEcho/2.0.0.8pre.

STR:
1. Install the Google Desktop application by running the installer.
2. After it installed, type Firefox in the search box.
3. After Minefield launches, note that Google Desktop in listed in the Addons Manager but is incompatible. If you try to uninstall it, it will not uninstall.  Should this instead be listed as a plugin? Confusing to users since it looks like a typical addon.  Also, with a fresh profile I still see it appearing in EM, which is a separate but also confusing issue.

Comment 1

11 years ago
Additionally, this is supported on Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.8) Gecko/20071004 Firefox/2.0.0.8. 

It also behaves the same as minefield, where uninstalling the extension via Tools > Addons, will restart and make no impact.  

My question is, if GDS is a desktop application, then it shouldnt be shown in the Extension window right?   instead, shouldnt it be treated like a plugin, and be listed on the About:plugins page?

Well, here's the problem. At least for Ff 1.5, there's no global extensions dir, so we have to add it for each user's profile. On uninstall, we can't necessarily get to all user's homedirs because they may not be mounted, or be FileVaulted, so we cannot uninstall it. So we punted.

Does ff2 have the global extension directory? That still doesn't help us for users that have 1.5. 
ohhh sorry, i misread. we do keep re-installing the extension, but I could have sworn we only do that for Firefox, not Minefield or anything else. 

Stuart, do you recall the logic there?

Comment 4

11 years ago
There's no difference between a Firefox profile and a Minefield profile; it's the same folder. IIRC, Minefield looks the same as Firefox in terms of the binary that it run as well. So yes, it will keep being installed, and be incompatible because we don't yet support trunk. This is the expected behavior of GD.

(In reply to comment #1)
> instead, shouldnt it be treated like a plugin,
> and be listed on the About:plugins page?

I don't follow. GD integrates with Firefox in the form of a Firefox extension; why would it make more sense for that to show up as a plugin?

Comment 5

11 years ago
(In reply to comment #4)
> I don't follow. GD integrates with Firefox in the form of a Firefox extension;
> why would it make more sense for that to show up as a plugin?
> 
i misunderstood how the extension worked.  since its not a plugin, disregard my last comment.

Is there a better way we can handle this expected behavior?   Its easy for a normal user to get confused if trying to uninstall it via addons manager, and not seeing that happen.   We arent aware of any other extensions that behave this way that are currently out there.

Comment 6

11 years ago
I'm not aware of any other system-wide applications that need to integrate with Firefox via an extension. If there's a better way to load something with extension-like behavior into every current and future profile, that would be great.

Comment 7

11 years ago
Dave, any thoughts here? 
The only global area to install extensions that exists in mac is within the firefox app-bundle itself, so if you were to create your link file/directory at /Applications/Firefox.app/Contents/MacOS/extensions/<id> it would be installed whenever running firefox.

As an added bonus, if you have your extension there you can add an em:locked property to the install.rdf. Set to true it makes it so the user cannot uninstall the extension, however can still disable it for their profile.

The only spot where this falls down of course is that removing/replacing the app bundle would lose the extension, however standard software update shouldnt affect it.

Updated

9 years ago
Duplicate of this bug: 435017

Comment 10

9 years ago
Platform "All" as duplicate bug 435017 was filed on PowerPC architecture. 

--> Toolkit, Add-Ons manager. 

Documentation on this topic. 

http://support.mozilla.com/en-US/kb/Cannot+uninstall+an+add-on
Component: Plug-ins → Add-ons Manager
Product: Core → Toolkit
QA Contact: plugins → add-ons.manager
Hardware: x86 → All
As it stands this bug is invalid. It is Google Desktop reinstalling the extension that is the issue.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID

Updated

9 years ago
Blocks: 495687

Comment 12

9 years ago
As 495687 is currently titled, it is inaccurate to say that this block that bug; users have total control over whether or not this extensions is installed, via the GD preference pane in System Preferences. It can't be controlled through the add-on manager for technical reasons discussed, but it is absolutely not the case that users don't control it.
No longer blocks: 495687
You need to log in before you can comment on or make changes to this bug.