tab bar does not focus on new tabs

VERIFIED WORKSFORME

Status

()

Firefox
Tabbed Browser
--
minor
VERIFIED WORKSFORME
11 years ago
11 years ago

People

(Reporter: Liam K., Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a8) Gecko/2007091216 GranParadiso/3.0a8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a8) Gecko/2007091216 GranParadiso/3.0a8

When I press Ctrl+T to open a new tab, Firefox switches to it, but the tab bar does not scroll to it.

Reproducible: Always

Steps to Reproduce:
1. Press Ctrl+T.
Actual Results:  
Tab bar does not scroll to new tab.

Expected Results:  
The tab bar should scroll over to the tab automatically.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a9pre) Gecko/2007102323 Minefield/3.0a9pre

Do you mean that the new tab is opened in the background? I can't reproduce this using a new profile with default settings and no add-ons.
(Reporter)

Comment 2

11 years ago
No. I left something out in the "Steps to Reproduce".

1. Have at least 6 tabs open, so the tab bar will scroll.
2. Press Ctrl+T

The window will show about:blank, and the address bar will be empty, but the bar under the toolbars that shows your tabs currently open will not scroll over to the new tab.

Comment 3

11 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b1) Gecko/2007110903 Firefox/3.0b1 ID:2007110903

I get the same behavior.  To replicate:
1 - Keep opening tabs until the tab bar starts to scroll
2 - Select the first, left most tab (or any tab that would cause the tab bar to scroll when a new tab is added)
3 - hit control+t to open a new, blank tab

Result: the browser window displays a blank page, but the tab bar does not scroll to show the current blank tab as being active.  All of the tabs in the visible tab bar are deactive.
I tested comment 3 with the latest trunk hourly, newly created profile without any add-ons on Windows XP, but couldn't reproduce the problem.

Comment 5

11 years ago
(In reply to comment #4)
> I tested comment 3 with the latest trunk hourly, newly created profile without
> any add-ons on Windows XP, but couldn't reproduce the problem.
> 

I tested again, this time in safe mode.  I couldn't replicate the bug. I'm chalking it down to an extension I forced into compatibility.
this is WFM testing FF3 beta 1 [Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9b1) Gecko/2007110904 Firefox/3.0b1]

as per comments 4 & 5 closing WORKSFORME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
OS: Windows 2000 → All
Resolution: --- → WORKSFORME
Version: unspecified → Trunk
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.