Open Java Console refuses to work under Firefox 2.0.0.8 - switches Java off instead

RESOLVED INVALID

Status

()

Firefox
Extension Compatibility
--
major
RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: Stewart Gordon, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.8) Gecko/20071008 Firefox/2.0.0.8

I'm not sure where this should really be filed.  It relates to the Open Java Console add-on, but it could be either a bug in Firefox itself or a compatibility change that the add-on just needs to be updated to.

Under Firefox 2.0.0.7, the Open Java Console add-on worked without trouble.  However, after the automatic upgrade to 2.0.0.8, I cannot get it to work at all.

Reproducible: Always

Steps to reproduce:
1. Have the Open Java Console add-on installed.

2. Have Java enabled.  Confirm this by issuing
    javascript:alert(navigator.javaEnabled())

3. Tools -> Java Console

4. Issue
    javascript:alert(navigator.javaEnabled())
again.

5. Tools -> Java Console again.


Actual results:
2. navigator.javaEnabled() returns true.

3. Nothing visibly happens.  The Java Console doesn't open.

4. navigator.javaEnabled() returns false.  However, under Tools -> Options -> Content, "Enable Java" is still ticked.

5. A message dialog box states "The Java support in the browser has been disabled."

The result is the same if I omit step 2 and/or 4.  If I disable and re-enable Java from Tools -> Options, it returns to the enabled state, and then the same steps produce the same result.

Tried restarting Firefox.  Tried restarting Windows.  Tried uninstalling and reinstalling the add-on (and yes, I did restart Firefox after each step here).  No change.

Expected results:
Opened the Java Console when I told it to, and not disabled Java without me telling it to.
The java console extension is not part of Firefox nor is it provided by Mozilla. Please report this bug to the extension's author.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Keywords: regression, useless-UI
Resolution: --- → INVALID

Comment 2

10 years ago
I have this same problem I think. I got the automatic update on Firefox to 2.0.0.8 maybe last week??? and now this one website will not load the game I love........scrabulous.com. And it was working fine before the update. I tried to uninstall JAVA on my computer and reinstall and it was no help. I run the Java test on IE and it says all is up to date on my Computer that I do not need to download anything after I re downloaded it. I have run the "Test your Java Virtual Machine (JVM)" on IE and it works fine and run the SAME test on Firefox and the little dancing man with the red circle in the middle does NOT show up. So it does NOT work. I have tried the enable/disable Java and this does not help. I have added the patch for "java console" because the original "java console" would just disappear when you clicked on it. I obviously am not a computer guru but to me the new Firefox update is to blame and somehow it needs to be fixed and I certainly cannot do it. Please let me know when there is a fix. Until then I have to go back to IE. Scrabulous works just fine there!!!!!!!!!!
You need to log in before you can comment on or make changes to this bug.