KB article: Pressing slash or apostrophe in text field opens find bar

VERIFIED FIXED

Status

VERIFIED FIXED
11 years ago
11 years ago

People

(Reporter: jason.barnabe, Assigned: Kensie)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Assignee)

Comment 1

11 years ago
Ready to get a once over.
(Reporter)

Comment 2

11 years ago
Content:
-Not a big fan of phrases like "There have been several issues" or "there are still some reports". Just get to point and say what the problem is.
-Ditto for "Some people have reported"
-Instead of saying the issues are mostly fixed in Firefox 2, suggest that the user check for updates. This could be the first heading.
-"Search for text when I start typing" should be named after what the section describes, like "Disabling text search" or something. "How to type in a text field if this bug is happening" could be "Workaround"
-Look at other articles for how to tell the user to open the Options dialog.
-"If you're having this issue, make sure this pref is off:" Use "setting" or "feature" instead of "pref".
-Do we have an article that describes this feature? If so, link to it in the intro.

Formatting:
-Use level 1 headers, not level 2
-TOC
-Missing some formatting in #2 and #3 in the first section.

Grammar and other nitpicks
-"focused" is the preferred spelling
-"Search for text when I start typing" - "you" instead of "I"

Comment 3

11 years ago
(In reply to comment #2)
> Content:
> -Not a big fan of phrases like "There have been several issues" or "there are
> still some reports". Just get to point and say what the problem is.
> -Ditto for "Some people have reported"
> -Instead of saying the issues are mostly fixed in Firefox 2, suggest that the
> user check for updates. This could be the first heading.

I agree with all the above.
If upgrading is ever a possible solution, list it as a solution, and make it first in the list.

> -"Search for text when I start typing" should be named after what the section
> describes, like "Disabling text search" or something. "How to type in a text
> field if this bug is happening" could be "Workaround"

I agree here as well.

> -"If you're having this issue, make sure this pref is off:" Use "setting" or
> "feature" instead of "pref".

I say skip the paragraph, and go straight to the steps.

> -Do we have an article that describes this feature? If so, link to it in the
> intro.

No article on that. Bug filing time. :-)

> Formatting:
> -Use level 1 headers, not level 2
> -TOC
> -Missing some formatting in #2 and #3 in the first section.

I don't see the need for a TOC on this one.

All KB articles are very consistent; so they should provide a good reference on how we want things to look.
(Assignee)

Comment 4

11 years ago
> -"Search for text when I start typing" - "you" instead of "I"
> 

"I" is the phrase in the options panel, but that should have a menu path formatting I guess?

Will take a shot at incorporating the rest of the feedback.
(Reporter)

Comment 5

11 years ago
(In reply to comment #3)
> > Formatting:
> > -Use level 1 headers, not level 2
> > -TOC
> > -Missing some formatting in #2 and #3 in the first section.
> 
> I don't see the need for a TOC on this one.

Not with two sections, but there'll be a third if "Update Firefox" is a section.

(In reply to comment #4)
> > -"Search for text when I start typing" - "you" instead of "I"
> > 
> 
> "I" is the phrase in the options panel, but that should have a menu path
> formatting I guess?

I was referring to the section heading, but I suggested to completely change it anyway.
(Assignee)

Comment 6

11 years ago
right, that's why I figured you were talking about the other thing.  So the problem I'm having with renaming the section is that it's basically "make sure this setting is off" since it's off by default or "if you have this on turn it back off"  Other problem is the function doesn't have a name to use in place of the UI text.  Of course I'm open to changing it, but I'm drawing blanks.

Some changes are already up, think I just need to fix the formatting now.
(Reporter)

Comment 7

11 years ago
Alright, much better. Here's a more thorough read-through.

-"Typing a / (slash) or ' (apostrophe) are shortcuts to open the Quick Find bar." -> "Typing a / (slash) or ' (apostrophe) opens the Quick Find bar." or "/ (slash) and ' (apostrophe) are shortcuts to open the Quick Find bar."
-"Check for Firefox Updates" lowercase U.
-"Updates could contain code fixes that will help alleviate or fix the problem altogether.": sounds too uncertain. How about "Most of the causes of this issue have been fixed in the latest version of Firefox. See ((Upgrading Firefox)) for instructions on how to get the latest version."
-Use the instructions for opening the Options dialog that other articles use, for example http://support.mozilla.com/kb/Images+or+animations+do+not+show
-"Advanced" should have the menu tag.
-"The General tab should be displayed, if not, click on it to select it.". I think you can just say "Click the General tab.".
-"Accessibility" and "Search for..." should be bolded, not menu tagged.
-In the workaround section, can you say something like "You can temporarily fix the problem by opening any Firefox dialog." instead of the intro?
-Lose the word "simply".
(Assignee)

Comment 8

11 years ago
I think I made most of the changes.

I haven't changed the section about the options window yet, first of all because the link you gave me refers to it as the "options" window.. "Open the Firefox Options window..." But it's not called the options window on anything but windows.  It is however called the menu bar on all 3, although I do appreciate that users might not know what that means.  IMO I'd rather go for proper terminology and clear it up with a screenshot, or a link to a glossary page.  Having said that, it's not the most important part of the article.  Please feel free to change it when you give it another once over, I'll defer judgment on this.  Just wanted to bring up those points first.

Comment 9

11 years ago
Does that mean this is ready for review?
(Assignee)

Comment 10

11 years ago
yes, did I forget to add the tag to this one?
I'm changing the instructions for accessing the options window. The term "menu bar" isn't something I'm confident Windows users will understand. It is only specified on Mac, because the menu bar is not part of the window, it is being used as a Mac term, rather than a Firefox term.
Moved to KB on Thu 29 of Nov, 2007 20:08 PST.
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
(Reporter)

Updated

11 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.