Closed Bug 401055 Opened 15 years ago Closed 15 years ago

using imagemap, <img ... usemap=#X> <map id=X..> node=getNodeById node.innerHTML = map.innerHTML causes image display to fail

Categories

(Firefox :: General, defect)

2.0 Branch
x86
Linux
defect
Not set
major

Tracking

()

VERIFIED DUPLICATE of bug 400421

People

(Reporter: papowell, Unassigned)

Details

(Keywords: regression, testcase)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.8) Gecko/20071008 FreeBSD/i386 Firefox/2.0.0.8
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.8) Gecko/20071008 FreeBSD/i386 Firefox/2.0.0.8

this was working in Firefox 1.xx and 2.0.0.0- 2.0.0.7, fails in
2.0.0.8.  Ummm... it would be nice to have this functionality to
allow updates of image maps in a simple and easy to do way.  Otherwise
we need to brutally construct them...
  Patrick ("A world without problems is probably pretty dull") Powell

start with an image and an image map:
<img src="image.png" usemap="#MYMAP">
<map id="MYMAP" name="MYMAP" ><area ....><area ....></map>

Now in some Javascript callback, say a button, do the following:
function test(){
  var node = document.getElementById("MYMAP");
  confirm("CURRENT MAP '"+node.innerHTML+"'");
  // now the evil update:
  node.innerHTML = node.innerHTML; // it better be correct
  --- at this point your displayed image disappears
}

Reproducible: Always

Steps to Reproduce:
1. See above
2.
3.
Actual Results:  
See Above

Expected Results:  
Image map updates, users click and get new image map actions.

Ummm...  there have been some comments that the DOM model really does not
support 'innerHTML' for <map> objects.  However, it has been working before.
This type of support really really is nice with AJAX like applications.

By the way, thanks for your efforts...  If any of the FireFox/Mozilla/Whatever
folks are in San Diego at the next Usenix/LISA conference,  I sponsor a Free Beer
and Munchies... Patrick Powell/LPRng, Astart Technologies, etc.
Attached file Testcase
Looks like another 2.0.0.8 regression...
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking1.8.1.10?
Keywords: regression, testcase
Version: unspecified → 2.0 Branch
Looks like a duplicate.  ;)  2.0.0.9 will fix this....
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 400421
Verified, testcase works in 2.0.0.9 on Linux
Status: RESOLVED → VERIFIED
Flags: blocking1.8.1.11?
You need to log in before you can comment on or make changes to this bug.