message with hundreds of URLs locks Thunderbird due to slow scam detection

RESOLVED DUPLICATE of bug 383718

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 383718
11 years ago
11 years ago

People

(Reporter: Denis Roy, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.8.1.8) Gecko/20071008 Firefox/2.0.0.8
Build Identifier: version 2.0.0.6 (20070728)

I often receive small-ish e-mail messages (300K - 600K) but with hundreds of http:// URLs in it.  Upon clicking the message, TB just freezes, using 100% CPU and I must kill it.

Reproducible: Always

Steps to Reproduce:
1. Send an e-mail to an IMAP account with several hundred http://some.url.com/someurl, one per line
2. Watch as TB struggles


Expected Results:  
TB should be able to show me the email without locking up.

Sample email:

indexer[19931]: indexer from mnogosearch-3.3.4-mysql started with '/home/apps/mnogosearch/etc/indexer.conf'
indexer[19931]: [19931]{01} URL: http://wiki.eclipse.org/FAQ_How_do_I_find_out_what_object_is_selected%3F
indexer[19931]: [19931]{01} ROBOTS: http://wiki.eclipse.org/robots.txt
indexer[19931]: [19931]{01} URL: http://wiki.eclipse.org/FAQ_What_books_have_been_written_on_Eclipse%3F
indexer[19931]: [19931]{01} URL: http://wiki.eclipse.org/BIRT/FAQ/Extensions
indexer[19931]: [19931]{01} URL: http://wiki.eclipse.org/WTP_Bugs,_Workflow_and_Conventions
indexer[19931]: [19931]{01} URL: http://wiki.eclipse.org/DSDP/TM/Inter-Debugger_Communications
indexer[19931]: [19931]{01} URL: http://wiki.eclipse.org/IHE_Test_Server_Information
indexer[19931]: [19931]{01} URL: http://wiki.eclipse.org/ATF/Mozilla

... and on and on for 400 KB.
(Reporter)

Comment 1

11 years ago
More information:

- my IMAP account is an imaps account.  I don't think that should matter.

- while TB is frozen/locked, there is no network or disk activity, but CPU is at 100%

- Moving the message to a local folder and clicking on the message in the local folder still causes TB to struggle, but it does eventually allow me to see the entire message

- My unqualified assumption is that the high URL count is causing strain on the Junk/Scam engine in TB
(Reporter)

Comment 2

11 years ago
(In reply to comment #1)
> - My unqualified assumption is that the high URL count is causing strain on the
> Junk/Scam engine in TB

Apologies for all the e-mail ... Indeed, disabling the "Email Scams" option in Thunderbird Preferences solves the problem, so this is a bug with the Scam determination.

Updated

11 years ago
Summary: IMAP message with many URLs locks Thunderbird → message with hundreds of URLs locks Thunderbird due to slow scam detection
(In reply to comment #2)
> disabling the "Email Scams" option in Thunderbird Preferences solves the problem

Could you add comment about this workaround into Bug 383718?
(Reporter)

Comment 5

11 years ago
Indeed, a dupe. We're also using the same indexing software.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 383718
You need to log in before you can comment on or make changes to this bug.