Some ARIA Buttons fail to be rendered as such (effective Sep 29, 2007)

RESOLVED INVALID

Status

()

Core
Disability Access APIs
--
major
RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: MarcoZ, Assigned: Aaron Leventhal)

Tracking

(Blocks: 1 bug, {access, regression})

Trunk
x86
Windows XP
access, regression
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.9 ?

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
On the above given page, which is an ARIA button example, the buttons are no longer rendered as buttons, but as clickables, starting build 2007-07-29.
Other examples, such as the Mozilla XHTML button example, are not affected.
Flags: blocking1.9?
(Reporter)

Comment 1

10 years ago
The checkins for the period in question are http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2007-09-28+00%3A00&maxdate=2007-09-29+03%3A45&cvsroot=%2Fcvsroot
(Reporter)

Comment 2

10 years ago
Aaron, while investigating this, I noticed that on the page given in the URL field, the button title was not correctly converted to the button's caption in builds up to 2007-09-28. Do you want a separate bug filed for that?
Starting with builds 2007-09-29, the title is still not used, but now, the image's SRC is used as the caption for the clickable.
(Assignee)

Updated

10 years ago
Keywords: regression
(Assignee)

Updated

10 years ago
Blocks: 343213
(Assignee)

Comment 3

10 years ago
I believe this is intentional behavior. We sent out a message to related newsgroups and known ARIA implementors that we're changing how we process markup and that people would need to change their code.

It's the result of our fix for 
https://bugzilla.mozilla.org/show_bug.cgi?id=397100

We're aiming torward
http://simon.html5.org/specs/aria-proposal

This means we won't allow the role attribute to be namespaced in HTML anymore. It won't be recognized. It will also still work in Firefox 2 if you just use |role| in no namespace on an HTML element.

The problem in the example for this bug is the line:
setAttrNS(elmAccessible, NS_XHTML2, "role", "wairole:" + sClass);

If it still wants to set the role attribute in JS, then it can just do:
element.setAttribute("role", "wairole:" + sClass);

Marking INVALID because this is the cause of authors not catching up to the changes that we published.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.