"Download Headers" dialog gives too little contextual information for a11y

RESOLVED FIXED

Status

Thunderbird
Mail Window Front End
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: MarcoZ, Assigned: MarcoZ)

Tracking

({access})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

2.44 KB, patch
Aaron Leventhal
: review+
neil@parkwaycc.co.uk
: superreview+
Details | Diff | Splinter Review
(Assignee)

Description

10 years ago
To reproduce:
1. Subscribe to a newsgroup you know has many messages (over 500).
2. Highlight it in the Folder pane.
3. The "Download headers" dialog comes up. This does not provide much contextual information for the radio buttons, and the edit field is only labelld with the word "headers", which does not make for a good screen reading experience.
(Assignee)

Comment 1

10 years ago
Created attachment 286187 [details] [diff] [review]
Patch addressing a11y reading issues.

1. Add the two description fields as labels to the radio group element, giving immediate contextual information when tabbing to the radio buttons.
2. Give the textbox a label that consists of the radio button's label, the currently entered number, and the word "headers" from the label. This gives a much better reading experience for visually impaired users.
Attachment #286187 - Flags: review?(philringnalda)
Comment on attachment 286187 [details] [diff] [review]
Patch addressing a11y reading issues.

Sorry, thought I opted out of this one yesterday - my review doesn't actually carry any weight in mailnews/, only mail/, and certainly not for aaa since I don't know the first thing about it ;)
Attachment #286187 - Flags: superreview?(neil)
Attachment #286187 - Flags: review?(philringnalda)
Attachment #286187 - Flags: review?(aaronleventhal)

Comment 3

10 years ago
Comment on attachment 286187 [details] [diff] [review]
Patch addressing a11y reading issues.

>         <label value="&headers.label;" accesskey="&headers.accesskey;"
>-               control="number"/>
I don't think this can be right - won't you lose accessibility?
(Assignee)

Comment 4

10 years ago
(In reply to comment #3)
> (From update of attachment 286187 [details] [diff] [review])
> >         <label value="&headers.label;" accesskey="&headers.accesskey;"
> >-               control="number"/>
> I don't think this can be right - won't you lose accessibility?

In this case, it is right, because the label becomes part of the |aaa:labelledby| attribute for the textbox above the label.

Comment 5

10 years ago
Comment on attachment 286187 [details] [diff] [review]
Patch addressing a11y reading issues.

We're mixing labels and descriptions here. If those descriptions are really labels, they just use the <label> element.

Second, the <radio> element should have the same labelledby as the textfield, so that when it gets selected all the relevant info is spoken, including the contents in the textfield and the static text after it.
Attachment #286187 - Flags: review?(aaronleventhal) → review-
(Assignee)

Comment 6

10 years ago
Created attachment 286534 [details] [diff] [review]
Second patch

1. The description that contains the sentence "there are <xxx> headers in this newsgroup." has been converted to a label and associated with the radio group.
2. The "some" radio button now is labelled with the full sentence.
3. The label now has the control attribute back so you can still click on the word "headers" and get the focus into the text field.

Thanks for the pointers!
Attachment #286187 - Attachment is obsolete: true
Attachment #286534 - Flags: superreview?(neil)
Attachment #286534 - Flags: review?(aaronleventhal)
Attachment #286187 - Flags: superreview?(neil)

Updated

10 years ago
Attachment #286534 - Flags: superreview?(neil) → superreview+

Comment 7

10 years ago
Comment on attachment 286534 [details] [diff] [review]
Second patch

r+ but what about the description? Shouldn't it be associated with something via the control attribute?
 <description class="header" style="width: 25em; max-width: 25em;" id="newsgroupLabel"/>
Attachment #286534 - Flags: review?(aaronleventhal) → review+
(Assignee)

Comment 8

10 years ago
(In reply to comment #7)
> r+ but what about the description? Shouldn't it be associated with something
> via the control attribute?
>  <description class="header" style="width: 25em; max-width: 25em;"
> id="newsgroupLabel"/> 

It only contains the newsgroup name, which gets added at run-time. Not sure what it should be associated with.
(Assignee)

Updated

10 years ago
Attachment #286534 - Flags: approval-thunderbird3?

Comment 9

10 years ago
Okay, I'm looking at the dialog now. I should have done that earlier

mozilla.dev.apps.firefox
There are 6246 message headers to download for this newsgroup.
( ) Download all headers
( ) Download ____ headers
    [ ] Mark remaining headers as read

The newsgroup name as the top, in this case "mozilla.dev.apps.firefox" -- that acts as a label for the radiogroup. It should be a <label>
The next line, which says how many headers there are to download, that should really be a <description> for the radio group.

The difference between a label and a description is that a label tells you what something is, where as a description provides supplemental information that helps understand it better.
(Assignee)

Comment 10

10 years ago
Comment on attachment 286534 [details] [diff] [review]
Second patch

Taking back approval request, will submit another updated patch later that should then go in.
Attachment #286534 - Flags: approval-thunderbird3?
(Assignee)

Comment 11

10 years ago
Created attachment 286579 [details] [diff] [review]
Patch 3

1. The newsgroup field is now a label that is associated with the radio group.
2. The sentence has been reverted to a description, and also associated with the radio group, which will make it the radio group's AccessibleDescription.
Attachment #286534 - Attachment is obsolete: true
Attachment #286579 - Flags: superreview?(neil)
Attachment #286579 - Flags: review?(aaronleventhal)

Updated

10 years ago
Attachment #286579 - Flags: review?(aaronleventhal) → review+

Updated

10 years ago
Attachment #286579 - Flags: superreview?(neil) → superreview+
(Assignee)

Updated

10 years ago
Attachment #286579 - Flags: approval-thunderbird3?
You don't need approval-thunderbird3, and won't for... quite a while, I'd guess. Not quite sure why we have that flag that's only needed in the final stages of a release push visible already.
Keywords: checkin-needed
Attachment #286579 - Flags: approval-thunderbird3?
mailnews/news/resources/content/downloadheaders.xul 1.27
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.