lightning 0.7 x86_64 packages

RESOLVED FIXED

Status

Calendar
General
--
major
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: Jan Vlug, Unassigned)

Tracking

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.1.8) Gecko/20071019 Fedora/2.0.0.8-1.fc7 Firefox/2.0.0.8
Build Identifier: 

Please provide 64 bit packages for Linux.

Reproducible: Always

Comment 1

10 years ago
I've created a build and placed it here:
http://rapidshare.com/files/66358246/lightning-0.7-tb-linux-x86_64.xpi.html

Please make this accessible in the 0.7/contrib FTP folder. 

Comment 2

10 years ago
Builds added to ftp.mozilla.org

Links are on http://www.mozilla.org/projects/calendar/releases/lightning0.7.html#contributedbuilds
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
What thunderbird build are those lightning packages for? I mean, the i386 lightning builds are pretty specific for the mozilla.org provided thunderbird builds. They are unlikely to work on other (distro provided) builds. The same would go for x86_64. So you should specify for what kind of builds this lightning would work.
(Or dare I say that we should remove the lighting builds? I guess they are distro specific, and we don't carry disto-specific i386 build either)

Comment 4

10 years ago
Your answer should be found in the filename:  lightning-0.7-tb-linux-x86_64.xpi.

They're built for the x86_64 platform and are working fine with my Fedora 7 x86_64 thunderbird install.
I have a hard time believing that it really works on all x86_64 thunderbird builds. i386 builds don't work on all i386 tb builds either, so why would it be different for x86_64?

Comment 6

10 years ago
Then give it a try and post your results.
From what I know, the trick is you need the same ABI version on the compiler you are using and the compiler used to compile thunderbird. This is true for both i386 and x86_64 This is also the reason that some distros' icedove don't work with lightning.

If the stock thunderbird from ftp.mozilla.org works with these lightning builds, I think everything is fine.
There is no x86_64 thunderbird build on ftp.mozilla.org.

All I'm asking for is to add the distro name to the filename. Is that too much to ask?

Comment 9

10 years ago
Adding the distro to the filename isn't a big deal.  Without testing with other distros, however, it could be improperly limiting who the build would work for.  It would be nice to get some feedback from other users with x86_64 thunderbird installed in other distros (Suse, Debian, Ubuntu, etc.).

If the distro *were* to be added to the filename, it would need to be:
lightning-0.7-tb-linux-x86_64-fc7.xpi
The build doesn't work in my fedora 6. (which has thunderbird 1.5)
I'm not really sure why, because it claims that the extension is not compatible with Linux-x64_86-gcc3, but the extension claims to be compatible with that.
Anyway, it does not work.

And without testing other build, it would be improperly claiming to work. That's just as bad as improper limiting, if not worse.

Comment 11

10 years ago
Well, it's not clear if it's a distro problem or a thunderbird version issue.  It was built for thunderbird 2.0; not 1.5.  It would be nice to get clarification on this so we can name the file appropriately.  The filename may need to have the thunderbird version in it instead of the distro:

lightning-0.7-tb-2.0-linux-x86_64.xpi
You need to log in before you can comment on or make changes to this bug.