Open-with downloads should not be read-only on Mac, which does not use a temp dir for them

RESOLVED FIXED in mozilla1.9beta4

Status

Core Graveyard
File Handling
RESOLVED FIXED
10 years ago
2 years ago

People

(Reporter: Mardak, Assigned: Mardak)

Tracking

({regression})

Trunk
mozilla1.9beta4
All
Mac OS X
regression
Bug Flags:
blocking1.9 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

10 years ago
Created attachment 286353 [details] [diff] [review]
v1

I've been running into "override r--------  " when "rm <file>" from Terminal. Finder happily deletes the file though. ;)

These are downloads on my desktop that are open-with (typically pdfs opened in preview).

Note that only for os x do we keep the file around instead of deleting it by default... we should only really need to set the readonly bits if we're going to delete anyway.
Flags: blocking1.9?
Attachment #286353 - Flags: superreview?(cbiesinger)
Attachment #286353 - Flags: review?(cbiesinger)

Updated

10 years ago
Flags: blocking1.9? → blocking1.9-
Attachment #286353 - Flags: superreview?(cbiesinger)
Attachment #286353 - Flags: superreview+
Attachment #286353 - Flags: review?(cbiesinger)
Attachment #286353 - Flags: review+
(Assignee)

Updated

10 years ago
Attachment #286353 - Flags: approval1.9?

Updated

10 years ago
Attachment #286353 - Flags: approval1.9? → approval1.9-
Can you elaborate on what this code does?  Maybe add a test case?
(Assignee)

Comment 2

10 years ago
The code fixes the regression from bug 280419 that makes temporary files read-only, but it shouldn't do that for OS X where the temporary files remain on the Desktop.

biesi: Do you see any way to test this? We would need to launch an application with an exthandler-downloaded file and check the permission before the application returns (because otherwise the file would be deleted).
Any update on this? Is this still an issue? Seems like this regression would need to be fixed to make the dlmgr completely useful.

Comment 4

10 years ago
Comment on attachment 286353 [details] [diff] [review]
v1

Asking approval again, seems unclear why it was minused in the first place.
Attachment #286353 - Flags: approval1.9- → approval1.9?
Comment on attachment 286353 [details] [diff] [review]
v1

a1.9+=damons
Attachment #286353 - Flags: approval1.9? → approval1.9+
(Assignee)

Comment 6

10 years ago
Checking in uriloader/exthandler/nsExternalHelperAppService.cpp;
/cvsroot/mozilla/uriloader/exthandler/nsExternalHelperAppService.cpp,v  <--  nsExternalHelperAppService.cpp
new revision: 1.365; previous revision: 1.364
done
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9beta4

Updated

8 years ago
Summary: Open-with downloads are readonly → Open-with downloads should not be read-only on Mac, which does not use a temp dir for them

Updated

8 years ago
Duplicate of this bug: 418492
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.