Status

()

Firefox
General
RESOLVED WORKSFORME
10 years ago
6 years ago

People

(Reporter: Aliysius Tan, Unassigned)

Tracking

2.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-09-15])

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.8) Gecko/20071008 Firefox/2.0.0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.8) Gecko/20071008 Firefox/2.0.0.8

The URL that provides the results of a Google Desktop Search appears blocked-- namely, 
http://127.0.0.1:4664/search?
This problem is not encountered with Microsoft's internet explorer.

Reproducible: Always

Steps to Reproduce:
1.Do a Google Deskto serach
2.Click on the option to show results on the web.
3.It will not open.
"3.It will not open."

What is happening, Do you get an error and what for an error ?
(Reporter)

Comment 2

10 years ago
The URL that holds the results of the search produces an error message saying that either the site is not functioning or that there is a firewall blocking access by Firefox.
And Do you use a firewall software and which product ?
There is no known problem in Firefox that Firefox can't access any IPs except if it's blocked by a firewall (and that is not Firefox fault of course)
(Reporter)

Comment 4

10 years ago
The only firewall I have is the Windows XP firewall.  I have no problem of this kind when I use Internet Explorer.

Comment 5

10 years ago
I get this too. I'm using McAfee but I don't see how it could be the firewall.

Comment 6

10 years ago
Same problem here:
I've had this problem before but installing a new version of google desktop fixed it (also enabling web search fixed it, but i've tried that and it doesn't change a thing).
Google Desktop doesn't give problems in firefox 2.
Error message translated from Dutch):

Error while connecting
Firefox can't connect to the server on 127.0.0.1:4664.

Other services from Google Desktop (preferences, about,...) can be used on 127.0.0.1:4664
So I think it's a problem of Google.

Comment 7

10 years ago
Extra Information:

I found out that if firefox is closed when using google desktop, everything works as expected (even when firefox is told to safe the tabs from the previous session). But when firefox is allready open, it gives the error as described in the previous posts.

Comment 8

10 years ago
Sorry for the tripple post, but i've discoverd (i promise next time i first play around an extra day before posting a bug) that if you search, get the error and the refresh, you get the page you'd expect in the first place...

Comment 9

10 years ago
Identical problem here. Firefox 2 and IE are fine; Firefox 3b3 doesn't allow GDS searches to port 4664. Error is "Firefox can't establish a connection to the server at 127.0.0.1:4664."

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3) Gecko/2008020514 Firefox/3.0b3 

Comment 10

10 years ago
I can connect to http://localhost:4664/search or http://127.0.0.1:4664/search (which shows Google Desktop, although it is not a valid query), but if I add a query string to the URL, I can't establish a URL. E.g., the following give the error "can't establish a connection":

http://localhost:4664/search?
http://127.0.0.1:4664/search?

I suggest this is a fairly high priority bug for FF3 because Google Desktop is so widely deployed.

Comment 11

10 years ago
Seems to be working again in firefox 3b4...

Comment 12

10 years ago
Does not work for me 3b4. Exactly the same behavior as previous betas.

Comment 13

10 years ago
I can't prove it, but I'm pretty sure without upgrading Firefox this works sometimes and at other times you get the error. If so this will make it difficult to test, but might also explain why some people don't think it's a bug.

Comment 14

10 years ago
Actually, my last post isn't quite right either. I *can* access to the Google Desktop local home page:

http://127.0.0.1:4664/&s=fh-UIqVq-xL_f8H6cVJ0tTXj32w

But as soon as I try to do a search I get the connection denied error.

Comment 15

10 years ago
Upgrading Google Desktop Search to 5.7.0802.22438-en-pb eliminate this problem for me.

Comment 16

10 years ago
The version 5.7.0802.22438-cs-pb is first version of Google Desktop I've ever been using and I have exactly the problem as it was desribed.

All pages are displayed OK except when I click Search or press Enter for searching anywhere in the Google Desktop's interface. Then I get error something like: Server exists but cannot be retrieved. (I have Czech version of Firefox so I don't know the exact message)

No other web browser does this error. I've tried IE 7, Opera 9.25, Safari 3.1. Everything works OK in all the cases.

Mozilla/5.0 (Windows; U; Windows NT 5.1; cs; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5

Comment 17

10 years ago
Sorry for posting twice "in a minute".

To make the description complete: As it was said a few posts above, when I click Retry (or how it is called in English) the page is displayed correctly.

And I've found another problem with Google Desktop.
If I want to add a place to search in or a place not to be involved in the search in Google Desktop's preferences, it doesn't work. The place should be immediately added below the Add button but it isn't. Again it works in all other web browser.

Comment 18

10 years ago
i have something very new and interesting to provide to this problem, which i too am experiencing.  as the other posters have said, this will work fine on IE, and presumably it would work fine on ffox2, although i cannot confirm this because of very bizarre default program behavior.  And this is *likely* a firefox-related bug.  When I have minefield (current build) as default, google desktop tries (and fails) to search my computer and display the results in minefield.  if i switch the default to IE, google desktop will load as expected (with no errors) in IE.  However, if i then open Ffox2, and tell that to set as default, attempting a google desktop search does not do anything at all.  if minefield is then opened, it goes back to the above behavior (with the cannot connect to 127.0.0.1:4664 error).  If ffox2 is open, period, (with minefield installed), attempting a search does nothing.

Comment 19

9 years ago
Using XP+SP2 + FF 3.0.6 I have the same problem noted above even when using FF safe mode. As mentioned in comment #8, refreshing the page workarounds the problem!

Comment 20

8 years ago
This is WFM.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 
Google Desktop 5.9.0909.02235-en-pb

Comment 21

8 years ago
Also experiencing this bug here.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.8) Gecko/20100202
Firefox/3.5.8
Google Desktop 5.9.0911.03589-en-GB-pb

Steps to replicate:
- Goto the GDS start page (e.g. right click system tray icon and click 'Search Desktop')
- Search for some text, then middle-click on e.g. an email
- Observe the following in the new tab:
    Unable to connect
    Firefox can't establish a connection to the server at 127.0.0.1:4664.
- Hit F5 and see that this time the page is loaded correctly

What do we need to get this bug confirmed?

Comment 22

8 years ago
I've just reinstalled the latest GDS and this is now fixed! I can now open GDS result links in new tabs in Firefox successfully without getting the 'Unable to connect' page.

I moved from:
Google Desktop 5.9.0911.03589-en-GB-pb
to
Google Desktop 5.9.1005.12335-en-GB-pb

I don't know if it was the new version or just the reinstall itself that fixed it, but I'd recommend that anyone following this bug also tries a reinstall of the latest GDS version.
Reporter, are you still seeing this issue with Firefox 3.6.x or later in safe mode? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles
Whiteboard: [CLOSEME 2010-09-15]
Version: unspecified → 2.0 Branch

Comment 24

7 years ago
I haven't seen this problem in a long time. I would note that Firefox in "offline mode" doesn't allow GDS use where it really should; not sure if that is a bona fide bug or not, but probably unrelated to this old one.

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.