large messages always downloaded again when viewing even if imap folder is marked for offline use

RESOLVED DUPLICATE of bug 436615

Status

RESOLVED DUPLICATE of bug 436615
11 years ago
10 years ago

People

(Reporter: ronald.riemvis, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1)
Build Identifier: Versie 2.0.0.6 (20070728)

Using MAPI as protocol over the internet i found out that a map marked as offline use is not behaving as expected. The files are not downloaded to the local PC. I would expect that after downloading the email and use Thunderbird the program will look local if the message already excist and load then from HDD or else doenload it to store on the HDD. This all with the idea to increase the speed of reading.
Now with every connection and asking the same email i have to wait a long time before the email become visible, because of the many attachments of this email

Reproducible: Always

Steps to Reproduce:
1.Connect Thunderbird with use of Mapi to a server
2.Make a folder ready for offline use and download the messages
3.Look to an message
4.Quit the program
5.Start Thunderbird and look again to the same message
Actual Results:  
In both cases the email will be fetched from the server instaed of the HDD

Expected Results:  
Slow reading of messages

In offline and onlien mode compare the information on HDD or remote. When a mao is marked as offline the filoes will be downloaded to the HDD and when needed loaded from the HDD instead everytime from the remote server.
Mapi? You mean IMAP, right? Dupe/related: bug 235942.
(Reporter)

Comment 2

11 years ago
Yep, Sorry the IMAP protocol.

Updated

11 years ago
Summary: Mapi Offline download is not working → large messages always downloaded again when viewing even if imap folder is marked for offline use

Updated

11 years ago
Duplicate of this bug: 404088

Comment 4

11 years ago
As workaround use hidden option to sync everything and everywhere
mail.server.default.autosync_offline_stores = TRUE

Comment 5

11 years ago
related bug 329229?

Updated

10 years ago
Component: General → Backend
Product: Thunderbird → MailNews Core
QA Contact: general → backend

Comment 6

10 years ago
This one fixed on TB3 trunk by bug 436615
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
OS: Windows XP → All
Hardware: x86 → All
Resolution: --- → DUPLICATE
Duplicate of bug: 436615
You need to log in before you can comment on or make changes to this bug.