Closed Bug 401420 Opened 13 years ago Closed 11 years ago

Integrate all five applications into only one

Categories

(SeaMonkey :: General, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: landemaine, Unassigned)

Details

User-Agent:       Opera/9.24 (Windows NT 5.1; U; en)
Build Identifier: 

If we think about it, all five applications (Browser, Mail client, Chat client, Address book and HTML Editor) are all separate applications (pretty much like Firefox, Thunderbird and n|vu).

I suggest merging all of them and having them listed in the sidebar of the browser, like Opera (with Sunbird, ideally). When you open one of them, it is displayed in a tab and well organized (ie: one tab is the Inbox, another one is the address book, another tab lists Chatzilla's discussion tab, etc...). Of course if you don't open the application, you don't see its tab.

You could share even more libraries to use less memory that having all applications open at the same time. And this way we would have only one application open in the system taskbar (icing on the cake).

Reproducible: Always
(In reply to comment #0)
> If we think about it, all five applications (Browser, Mail client, Chat 
> client, Address book and HTML Editor) are all separate applications (pretty 
> much like Firefox, Thunderbird and n|vu).

Address book is not (yet) a separate application, see bug 256831.
 
> When you open one of them, it is
> displayed in a tab and well organized (ie: one tab is the Inbox, another one 
> is the address book, another tab lists Chatzilla's discussion tab, etc...). 

See Suite bug 132166.

> You could share even more libraries to use less memory that having all
> applications open at the same time. 

This might be possible someday when Firefox (bug 315452), Thunderbird (bug 306324), Chatzilla (bug 267477) and Sunbird (bug 337454) can share their XULRunner runtime. But the combination of these applications would not be the SeaMonkey suite -> moving to Core.
Assignee: general → nobody
Product: Mozilla Application Suite → Core
QA Contact: general → general
SeaMonkey contains the browser, mailnews (+addrbook), and chatzilla already. Therefore the only thing left to integrate all five applications is to pop in lightning, bug 313822. Therefore duping to said bug.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 313822
Status: RESOLVED → VERIFIED
Joshua, please reread the feature request. Your answer isn't related to the feature request. Seamonkey does ship with the aforementioned applications, however, they are not integrated into one single program when they are running. If you have the browser, the address book and the email client open, they are two separate applications in the task bar, they are not listed on Seamonkey's sidebar and they are not organized in tabs.
Status: VERIFIED → UNCONFIRMED
Resolution: DUPLICATE → ---
Product: Core → SeaMonkey
QA Contact: general → general
Version: unspecified → Trunk
There are no plans to change this to work different than SeaMonkey is now, so this is invalid.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago11 years ago
Resolution: --- → INVALID
OK. All my ideas to revamp Seamonkey have been discarded over the last 2+ years. I won't make anymore suggestions.
Actually, organized in tabs or not, all windows (Browser, Mail 3-pane, Message read, Message Compose, Address Book, Preferences, Download Manager, Add-ons Manager, ChatZilla, whatever) are managed by a single instance of the binary with a single copy of any library, even if used by several components and even if showing distinctly on the taskbar. Putting everything into a single window might perhaps make it harder to have the mailer on one virtual desktop and the browser on another the way I do now. Also, having only one taskbar icon would mean unncessary slowing of the workflow since in order to go from (let's say) Vim to SeaMonkey I would have to (1) click the single Sm icon, then (2) select the right component (often two clicks) rather than simply select the right window in the taskbar (only one click).

I suppose this RFE could have been resolved WONTFIX rather than INVALID (anyone may propose any "enhancement" but that doesn't mean it'll be accepted) but the boundary between these two resolutions is not always clear-cut.

Robert, Joshua, Stefan, and any watchers, sorry for the spam.
You need to log in before you can comment on or make changes to this bug.