Bogus folders listed in save-bookmark/star hanger

VERIFIED FIXED in Firefox 3 beta3

Status

()

Firefox
Bookmarks & History
P4
normal
VERIFIED FIXED
10 years ago
8 years ago

People

(Reporter: Dolske, Assigned: mano)

Tracking

Trunk
Firefox 3 beta3
x86
Mac OS X
Points:
---
Bug Flags:
blocking-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

10 years ago
When saving a bookmark, the Folders <select> offers me these choices:

============================
All Bookmarks
Bookmarks Menu
Bookmarks Toolbar
-----
Bookmarks Toolbar Folder
Bookmarks
Misc
Mozilla
jwz
============================

1) The first 3 choices seem reasonable

2) "Bookmarks Toolbar Folder" is a duplicate of "Bookmarks Toolbar", no?

3) "Bookmarks"? Dunno where that's going to end up.

4) I have a "Misc" in my Bookmarks menu and a "Misc" on my toolbar. The ambiguity is my fault for naming that way, I suppose, but I can't figure out which on it's going to choose because some of the other folders in my menu and toolbar are not listed here...

4a) If these are supposed to be Bookmarks Menu folders, I'm missing the other two folders I have there.

4b) If these are supposed to be Bookmarks Toolbar folders, I'm missing 2 of the other folders there ("Mozilla" is a folder there too, and is listed)

5) I don't have a folder named "jwz" anywhere. I do have a bookmark titled "jwz", though. It's in the middle of the "Blogs" folder on my toolbar.
Flags: blocking-firefox3?
Flags: blocking-firefox3? → blocking-firefox3+
Target Milestone: --- → Firefox 3 M10
Target Milestone: Firefox 3 M10 → Firefox 3 Mx
Target Milestone: Firefox 3 Mx → Firefox 3 M11

Updated

10 years ago
Priority: -- → P4
Grr, it's a list of special folders+separator+recently used folders. FWIW, this is the way it works in FF2 as well.
Created attachment 289829 [details] [diff] [review]
patch
Assignee: nobody → mano
Status: NEW → ASSIGNED
Attachment #289829 - Flags: review?(dietrich)
Target Milestone: Firefox 3 M11 → Firefox 3 M10
I think that this can be easily confusing if the "special folders" are
duplicated in the MRU list, below, which probably happens a lot.

Why not just always make it:

Unfiled Bookmarks
Bookmarks Menu
Bookmarks Toolbar
------------------
MRU 1
MRU 2
MRU 3
MRU 4
MRU 5

Except if MRU n is one of the three above, just don't show it a second time.

It might actually be a lot clearer to show ...

Unfiled Bookmarks
Bookmarks Menu
Bookmarks Toolbar
-----------------
Recently Used         <-- disabled menuItem
 MRU 1
 MRU 2
 MRU 3
 MRU 4
 MRU 5

But that's a nice-to-have.
Comment on attachment 289829 [details] [diff] [review]
patch

r=me, thanks.
Attachment #289829 - Flags: review?(dietrich) → review+
hrm, actually - unless the old bookmarks dialog is going away soon, please update that as well.
Attachment #289829 - Flags: review+ → review-
Created attachment 291795 [details] [diff] [review]
Fix both dialogs
Attachment #289829 - Attachment is obsolete: true
Attachment #291795 - Flags: review?(dietrich)
Comment on attachment 291795 [details] [diff] [review]
Fix both dialogs

looks good, r=me. thanks for updating the other dialog.
Attachment #291795 - Flags: review?(dietrich) → review+

Updated

10 years ago
Duplicate of this bug: 407473
Target Milestone: Firefox 3 M10 → Firefox 3 M11
mozilla/browser/components/places/content/bookmarkProperties.js 1.69
mozilla/browser/components/places/content/bookmarkProperties.xul 1.31
mozilla/browser/components/places/content/editBookmarkOverlay.js 1.13
mozilla/browser/locales/en-US/chrome/browser/places/bookmarkProperties.dtd 1.14
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
verified with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre)
Gecko/2007121805 Minefield/3.0b3pre and the equivalent Mac nightly build. 
Status: RESOLVED → VERIFIED
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.