Recurrence dialog: Independent CSS style for days in minimonth

RESOLVED WORKSFORME

Status

Calendar
General
--
enhancement
RESOLVED WORKSFORME
11 years ago
11 years ago

People

(Reporter: Pete Riley, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7
Build Identifier: Lightning 0.8pre 2007-10-28-05

I can currently use CSS to style the days (1-31) in the minimonth.  For example:

.minimonth-day
{
     font-family: "Courier New" !important;
     font-weight: normal !important;
}

I would like to have two independent style classes:  one class for the minimonths in the recurrence dialog, and the existing class (.minimonth-day) for all others.

The reason is because I make all days unbold in the normal minimonth because I don't like the way that Lightning adds the bold attribute to days that have events -- the overall effect of the mixture of bold/unbold days looks too "busy" and is not useful for me.

The problem is that, because my CSS affects all minimonths, all days in the recurrence dialog are also unbold so I can't see which days are part of the recurrence pattern.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Try

#lefthandcalendar .minimonth-day,
#ltnMinimonth .minimonth-day {
    font-weight: normal;
}


If it works, please mark WFM.
(Reporter)

Comment 2

11 years ago
Hey Philipp, it works.  Thanks a lot!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.