When closing mail on Linux, window never goes away

VERIFIED WORKSFORME

Status

()

Core
XUL
P3
critical
VERIFIED WORKSFORME
18 years ago
18 years ago

People

(Reporter: Alec Flett, Assigned: Dan M)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dogfood+])

(Reporter)

Description

18 years ago
for some reason when you close the mail window on linux, the window never goes
away... 
it says "Clean up ..." on the console, which means the onunload handler is being
fired... also, the window stops being painted, so it's as though mozilla doesn't
think it's open even though it actually is.
(Reporter)

Comment 1

18 years ago
nominate for dogfood, this is really hurting my development because I have to
kill the process every time in order to quit & restart.
Keywords: dogfood

Comment 2

18 years ago
Actually, in this morning's release builds and previous, it crashes on exit 
everytime -- bug #39858.
Severity: normal → critical
(Reporter)

Comment 3

18 years ago
interesting.. I've been just using the close box in my window manager, so I 
hadn't seen that crash.

Comment 4

18 years ago
Putting on [dogfood+] radar.
Whiteboard: [dogfood+]
(Assignee)

Comment 5

18 years ago
I can't reproduce this. Probably the steps given are missing something vital. 
Here's what I've tried (with a build current as of about 3:30PM today):
  launch -mail, close using window manager widget.
  launch (-browser), open mail, close using WM widget.
  launch (-browser), open mail, fetch new messages, close using WM widget.
  all of the above, except close using the File Menu item.
The window closes as expected every time. Maybe I should mention that I use POP. 
I haven't tried IMAP; I'm getting a little bored trying to figure this one out. 
If IMAP is the important factor, I'd like to lobby that the mail/news guys take 
this bug over. Closing WFM and expecting to see more of this one.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

18 years ago
thanks for looking at this. I started seeing this on windows too, but my build 
is a day or two old. I'll reopen if it's still happening.

Comment 7

18 years ago
verifying wfm (Alec -- I'm assuming this is no longer a problem for you, 
right?)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.