After renaming a folder, using 'Move to "Folder"' in a message's context menu doesn't update the folder's name

RESOLVED DUPLICATE of bug 270871

Status

RESOLVED DUPLICATE of bug 270871
11 years ago
11 years ago

People

(Reporter: mark.gerber, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Opera/9.24 (Windows NT 5.1; U; de)
Build Identifier: Version 2.0.0.6 (20070728)

When using the message function 'Move to "Folder"' after renaming the destination folder two things can be seen: The context menu still shows the previous name of the last used folder and the message will (temporarily) disappear, when using this function.

Reproducible: Always

Steps to Reproduce:
1. Move a message to another folder (let's call the destination folder "Archive1").
2. Rename folder Archive1 to Archive2.
3. In any other folder open the context menu of a message.
4. Select the menu item 'Move to "Archive1"'.
Actual Results:  
The message disappears and cannot be found again.

Expected Results:  
The message should be moved to Archive2.

The moved message isn't actually lost. It is moved to the mail file of Archive1. After restarting Thunderbird, you can see both, Archive1 and Archive2. Archive1 contains the files moved after renaming Archive1 to Archive2.
Confirmed on linux/trunk.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
This is "rename" version of Bug 270871(refers to new / moved subfolder only).
See Bug 144684 and Bug 67982 also. Bug 67982 looks to be the first report. 
Ah, yes. Duping...
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 270871
You need to log in before you can comment on or make changes to this bug.