Crash [@ nsNavHistoryResult::OnItemRemoved][@ nsNavBookmarks::RemoveFolder] while deleting Places folder

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
--
critical
RESOLVED WORKSFORME
10 years ago
6 years ago

People

(Reporter: Martijn Wargers (dead), Unassigned)

Tracking

({crash})

3.6 Branch
crash
Points:
---
Bug Flags:
blocking-firefox3 -

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

10 years ago
I just crashed while deleting the Places folder in the Bookmarks manager.
This is totally unreproducable, so I'm marking it unconfirmed for now, but the crash is still there.

Related to bug 333109?

http://crash-stats.mozilla.com/report/index/f8a53254-861f-11dc-823b-001a4bd43ed6
0  	nsNavHistoryResult::OnItemRemoved(__int64, __int64, int)  	 mozilla/toolkit/components/places/src/nsNavHistoryResult.cpp:3920
1 	nsNavBookmarks::RemoveFolder(__int64) 	mozilla/toolkit/components/places/src/nsNavBookmarks.cpp:1343
2 	nsNavBookmarks::RemoveFolderTransaction::DoTransaction() 	mozilla/toolkit/components/places/src/nsNavBookmarks.h:228
3 	NS_InvokeByIndex_P 	mozilla/xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp:101
4 	XPCWrappedNative::CallMethod(XPCCallContext&, XPCWrappedNative::CallMode) 	mozilla/js/src/xpconnect/src/xpcwrappednative.cpp:2326
5 	XPC_WN_OnlyIWrite_PropertyStub 	mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp:511
(Reporter)

Comment 1

10 years ago
I'm still crashing with this on current trunk build.
Now, I got the crash while deleting the Smart bookmarks folder:
http://crash-stats.mozilla.com/report/index/a59b0214-d199-11dc-a39f-001a4bd43ef6
0  	@0x300061  	
1 	nsNavBookmarks::RemoveFolder(__int64) 	mozilla/toolkit/components/places/src/nsNavBookmarks.cpp:1412
2 	nsNavBookmarks::RemoveFolderTransaction::DoTransaction() 	mozilla/toolkit/components/places/src/nsNavBookmarks.h:232
3 	NS_InvokeByIndex_P 	mozilla/xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp:101
4 	XPCWrappedNative::CallMethod(XPCCallContext&, XPCWrappedNative::CallMode) 	mozilla/js/src/xpconnect/src/xpcwrappednative.cpp:2339

This might be difficult to reproduce, but it's a real crash!
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-firefox3?
Summary: Crash [@ nsNavHistoryResult::OnItemRemoved] while deleting Places folder → Crash [@ nsNavHistoryResult::OnItemRemoved][@ nsNavBookmarks::RemoveFolder] while deleting Places folder
not going to block on this at this time, doesn't seem to affect a lot of people and seems to be low impact.
Flags: blocking-firefox3? → blocking-firefox3-
(Reporter)

Comment 3

10 years ago
I don't think crashing is low impact, fwiw.
One report lately for Firefox 3.0.3: bp-f77f4aba-99d3-11dd-9389-001cc45a2c28

0  	xul.dll  	nsNavHistoryResult::OnItemRemoved  	 mozilla/toolkit/components/places/src/nsNavHistoryResult.cpp:4141

http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/toolkit/components/places/src/nsNavHistoryResult.cpp&rev=1.148&mark=4141#4141
two of these in the last two weeks, once on mac and once on windows.

search: http://bit.ly/Qd6I

this one indicates that it happened while sorting: http://crash-stats.mozilla.com/report/index/2b9cb158-d85f-40d9-8c7b-74b5f2090313
OS: Windows XP → All
Hardware: x86 → All
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
I still see these signatures reported in 3.6, so far no reports in 4.0.
Version: Trunk → 3.6 Branch
(Assignee)

Updated

7 years ago
Crash Signature: [@ nsNavHistoryResult::OnItemRemoved] [@ nsNavBookmarks::RemoveFolder]
I'm calling this fixed
Status: NEW → RESOLVED
Crash Signature: [@ nsNavHistoryResult::OnItemRemoved] [@ nsNavBookmarks::RemoveFolder] → [@ nsNavHistoryResult::OnItemRemoved] [@ nsNavBookmarks::RemoveFolder]
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.