Multiple dialogs (about, add-ons mgr, etc.) will not open (nsIDOMJSWindow.openDialog exception)

VERIFIED FIXED in mozilla1.9beta1

Status

()

Core
General
--
major
VERIFIED FIXED
10 years ago
10 years ago

People

(Reporter: reed, Assigned: peterv)

Tracking

({regression})

Trunk
mozilla1.9beta1
x86
Linux
regression
Points:
---
Bug Flags:
blocking1.9 +
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
Error: uncaught exception: [Exception... "Component returned failure code: 0xb78c6dba [nsIDOMJSWindow.openDialog]"  nsresult: "0xb78c6dba (<unknown>)"  location: "JS frame :: chrome://browser/content/utilityOverlay.js :: openAboutDialog :: line 318"  data: no]

Regressed sometime today, I think.
Flags: blocking-firefox3?
(Reporter)

Comment 1

10 years ago
From trying to open the add-ons manager:
Error: uncaught exception: [Exception... "Component returned failure code: 0xb77dd98a [nsIDOMJSWindow.openDialog]"  nsresult: "0xb77dd98a (<unknown>)"  location: "JS frame :: chrome://browser/content/preferences/main.js :: anonymous :: line 430"  data: no]

Pretty sure peterv's patch caused this.
Component: General → General
Flags: blocking-firefox3?
Product: Firefox → Core
QA Contact: general → general
Summary: About Dialog will not open (nsIDOMJSWindow.openDialog exception) → Multiple dialogs (about, add-ons mgr, etc.) will not open (nsIDOMJSWindow.openDialog exception)
Target Milestone: Firefox 3 M9 → mozilla1.9 M9
(Reporter)

Updated

10 years ago
Flags: blocking1.9?
Appears to be Linux-only, as this affects my Ubuntu Fiesty trunk build, but neither Mac OS X 10.4 nor Windows Vista.
(Reporter)

Updated

10 years ago
Blocks: 379718
(Assignee)

Comment 3

10 years ago
Created attachment 286660 [details] [diff] [review]
v1

Trivial fix, always initialize the result argument :-(.
Assignee: nobody → peterv
Status: NEW → ASSIGNED
Attachment #286660 - Flags: superreview?
Attachment #286660 - Flags: review?
Attachment #286660 - Flags: approvalM9?

Comment 4

10 years ago
confirmed, patch fixes issue.
Duplicate of this bug: 401703
Comment on attachment 286660 [details] [diff] [review]
v1

Um, the constructor is a bit ugly. But it was ugly even before your changes.
Attachment #286660 - Flags: superreview?(jst)
Attachment #286660 - Flags: superreview?
Attachment #286660 - Flags: review?
Attachment #286660 - Flags: review+
Flags: blocking1.9? → blocking1.9+
Comment on attachment 286660 [details] [diff] [review]
v1

jst: can you sr? this? It's now a M9 blocker so doesn't need explicit aM9+
Attachment #286660 - Flags: approvalM9?

Updated

10 years ago
Duplicate of this bug: 401770

Updated

10 years ago
Attachment #286660 - Flags: superreview?(jst) → superreview+
(Reporter)

Comment 9

10 years ago
Peter: If you can, please commit this before nightlies tonight. If you don't have time to or don't want to watch the tree, you can just add the checkin-needed keyword, and somebody will do it for you. Thanks! I really appreciate it. :)
(Assignee)

Updated

10 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(Reporter)

Updated

10 years ago
Duplicate of this bug: 401924
verified fixed using Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a9pre) Gecko/2007110106 Minefield/3.0a9pre

Open Dialogs (about, add-ons mgr) is now working fine -> Verified
Status: RESOLVED → VERIFIED
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.