Copy/Paste in OpenOffice

RESOLVED INVALID

Status

()

RESOLVED INVALID
11 years ago
11 years ago

People

(Reporter: rschermesser, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; fr-FR; rv:1.8.1.8) Gecko/20071022 Ubuntu/7.10 (gutsy) Firefox/2.0.0.8
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; fr-FR; rv:1.8.1.8) Gecko/20071022 Ubuntu/7.10 (gutsy) Firefox/2.0.0.8

When you paste the content of some webpages in OOo, the content of some tags is not copied.

It works with Konqueror but not with epiphany.
It works with Firefox and OOo on Windows.

The text that is not paste is in meta-tags (ex : <CIV>, etc).
If you remove all these meta tags it works !

Reproducible: Always

Steps to Reproduce:
1.Open this page in Firefox : http://questions.assemblee-nationale.fr/q13/13-8502QE.htm
2.Select all the text and copy it
3.Paste into OOo writer

Actual Results:  
Some of the text is not pasted

Expected Results:  
The hole text is pasted
I confirm this happens using Minefield 2007103004 on Ubuntu 7.04.  I am going to attach a screenshot comparing both for ease of reference.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Created attachment 286728 [details]
SCREENSHOT: Website
Created attachment 286729 [details]
SCREENSHOT: Pasted into OpenOffice
Component: OS Integration → DOM to Text Conversion
Product: Firefox → Core
QA Contact: os.integration → dom-to-text

Comment 4

11 years ago
I confirm it too.
(Reporter)

Comment 5

11 years ago
Hi,

I have made the same test with oocalc and it works. So the fault is in oowriter.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
This does not mean that the fault is in OO Writer.  This means that there is a problem between OOWriter and Firefox.  Unless you can find more solid proof that OOWriter is the offending app.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Let's consider this bug UNCONFIRMED until we can otherwise prove that it is not a Firefox bug.  If it turns out to be an OO bug, perhaps we can do the considerate thing and pass this information off to the OO team.
(Reporter)

Comment 8

11 years ago
I have posted a bug in the OOo tracker : http://www.openoffice.org/issues/show_bug.cgi?id=83447

I will try to seek the problem in OOo writer.
(Reporter)

Comment 9

11 years ago
This bug has been confirmed in OOo writer : http://www.openoffice.org/issues/show_bug.cgi?id=59064
(In reply to comment #9)
> This bug has been confirmed in OOo writer :
> http://www.openoffice.org/issues/show_bug.cgi?id=59064
> 

Sounds good to me.  Thanks for looking into this issue deeper.  I believe this bug can now be resolved as INVALID.
(Reporter)

Comment 11

11 years ago
Let's invalid this bug ! :)
Status: REOPENED → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.