Lightning is lacking the ability of exporting selected events

VERIFIED FIXED in 0.8

Status

--
enhancement
VERIFIED FIXED
11 years ago
6 months ago

People

(Reporter: pedro.madeira, Unassigned)

Tracking

unspecified

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.8) Gecko/20071019 Fedora/2.0.0.8-1.fc7 Firefox/2.0.0.8
Build Identifier: Lightning 0.7 final version

Lightning lacks the feature of exporting selected events as HTML that Sunbird can do.

In the implementation I have in my company, Marketing (has to) manually export next week's events to publish into a web server so that all users can view events in a web format when they don't have access to a computer with lightning installed. (not their laptop).

Since lightning is not able to export selected events (only has the hability to export the entire calendar) this forces marketing guys to have lightning integrated with their thunderbird but also sunbird just to be able to do this kind of export.

My suggestion is that this feature of exporting selected events should be incorporated into lightning.

Reproducible: Always
Works for me using Lightning 0.8pre (2007103004) nightly build. 
Fixed by the check in for Bug 390508.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Depends on: 390508
Resolution: --- → FIXED
(Reporter)

Comment 2

11 years ago
Confirmed. 0.8pre solves this issue.

Comment 3

11 years ago
Verified per Comment #1 and Comment #2 and with Lt 2007120504
Status: RESOLVED → VERIFIED
Summary: Lightning is lacking the hability of exporting selected events → Lightning is lacking the ability of exporting selected events
Target Milestone: --- → 0.8

Comment 4

3 years ago
Am I wrong, or this is no longer possible?? 

With Lightning-4.0.5.2 (on SeaMonkey), I can't find any function to export selected events, neither in the context menu of the "Find events" pane nor in the top menu tab "Events and Tasks." Only a whole calendar cna be exported.

According to this discussion http://forums.mozillazine.org/viewtopic.php?p=4765485, the feature was removed. If confirmed this bug should be *reopened*.

Please, give feedback.

Comment 5

2 years ago
Functionality seems to be missing in Lightning 4.0.6 with Thunderbird 38.6.0 on Linux.

Comment 6

2 years ago
The inability to export a selected subset of calendar events is STILL a HUGE BUG and MASSIVE FLAW!!! PLEASE FIX this incredible flaw!!!!

Comment 7

2 years ago
Last year I created a small extension to regain the ability to export single/selected events or tasks: https://www.nadelundhirn.de/wp/tag/export-calendar-selection/
It should still work, although I didn't do any updates since then. And there may be special cases I didn't cover/think of, I'm no pro. But basically the extension does what I want - it exports selections.

Comment 8

11 months ago
Thanks Robert! Works good here with Thunderbird 52 and Lightning 5.4
Quite a shame that a decade has gone by and this didn't got into Lightning yet.

Comment 9

11 months ago
(In reply to dllud from comment #8)
> Thanks Robert! Works good here with Thunderbird 52 and Lightning 5.4
> Quite a shame that a decade has gone by and this didn't got into Lightning
> yet.

Where can I find this "export-calendar-selection" extension? The above URL looks broken...

Comment 10

6 months ago
the URL works, and the extension works with thunderbird 52.1.0 - thank you :)
You need to log in before you can comment on or make changes to this bug.