allow opening links in default browser

UNCONFIRMED
Unassigned

Status

Mozilla Labs
Prism
--
enhancement
UNCONFIRMED
10 years ago
7 years ago

People

(Reporter: Matthew Scholtz, Unassigned)

Tracking

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.8) Gecko/20071008 Firefox/2.0.0.8
Build Identifier: 0.8 (Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a9pre) Gecko/2007102311 webrunner/0.7)

enable right-click or other affordance to open a link in OS default web browser instead of prism

that will allow us to keep prism focused on the 'app' it's being used for, but still open (and bookmark, etc.) other links in our normal browser

might be nice as well to have a setting to automatically open links that go outside of the original domain in the default browser

Reproducible: Always
Currently, all links outside the current domain are sent to the default browser.

I'll leave this bug open for the "Open in Browser" context menu option feature request
(Reporter)

Comment 2

10 years ago
I realized why I thought this doesn't work.
There seems to be a glitch where a trailing slash will cause the link to open in Prism?

Comment 3

9 years ago
Can someone confirm that this still occurs in Prism 0.9.1? I assume the problem has been fixed.

Comment 4

9 years ago
For me this still occurs in Prism 0.9.1

Scenario:
 - Created "Application" for Google Reader via menu item "Convert Website to Application"
 - Started application
 - Try to open links by clicking on headers
 - Links open in web app

I thought this is one of the basic features [1]: "Open external links in real browser". Importance is set a little too low for this issue (currently on "enhancement", or did I misunderstand something?

[1] https://wiki.mozilla.org/Prism#Prism_.2F_SSB_Objectives

Comment 5

9 years ago
That's odd, it works perfectly for me on Mac. I'll try to take a look on Linux if I have time.

Comment 6

9 years ago
Sorry, did not update the UA string, which definitely has changed since comment 1; It's FF 3.0.3 running on Vista:
Mozilla/5.0 (Windows; U; Windows NT 6.0; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3"

Comment 7

9 years ago
I'm also experiencing this bug with 1.0b on Ubuntu Jaunty 64-bit.

Comment 8

9 years ago
Tried again today after having received the update to Prism 1.0b1 (UA changed since my last comment: "Mozilla/5.0 (Windows; U; Windows NT 6.1; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4 (.NET CLR 3.5.30729)").

Everything seems to be working as expected.

Comment 9

7 years ago
This is not working for me. Ubuntu 10.04 and prism 1.0b4 installed with apt. 
Every links are loaded in a new prism window for that particular webapp. 

Tell me if there is something I can provide to help debugging the problem.

Comment 10

7 years ago
Same here with Ubuntu 10.10 and prism 1.0b3+svn20100210r62050-0ubuntu1
You need to log in before you can comment on or make changes to this bug.