When opening attachments make the temporary file read-only

RESOLVED DUPLICATE of bug 220808

Status

--
critical
RESOLVED DUPLICATE of bug 220808
11 years ago
11 years ago

People

(Reporter: erik-wikstrom, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.8.1.8) Gecko/20071008 Firefox/2.0.0.8
Build Identifier: 

When a user opens an attachment (as opposed to saving the attachment and then opening the file) and then makes changes to the attachment with the associated program these changes will appear to be lost to the user when they close the program (since most users will have no idea where the temporary file was created, and the file will be deleted when Thunderbird exits).

I propose to make the temporary file read-only so that the user is unable to save the changes to the temporary file and will be forced to save the modified copy in a location known to them.

Reproducible: Always

Steps to Reproduce:
1. Find a mail with a file which can be edited
2. Double-click the file and select open
3. Make changes to the file
4. Save the file
5. Close the application
6. Exit Thunderbird
Actual Results:  
The file is no longer available

Expected Results:  
The file should not be editable, thus forcing the user to save any changes to a separate file.
Should already be fixed for tb3.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 220808
You need to log in before you can comment on or make changes to this bug.