Last Comment Bug 401986 - Mac OS X leopard build failure in legacydb
: Mac OS X leopard build failure in legacydb
Status: RESOLVED FIXED
:
Product: NSS
Classification: Components
Component: Build (show other bugs)
: trunk
: x86 Mac OS X
: -- normal (vote)
: 3.12
Assigned To: glen beasley
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-31 19:33 PDT by glen beasley
Modified: 2007-11-07 12:05 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
remove white space (802 bytes, patch)
2007-10-31 20:11 PDT, glen beasley
rrelyea: review+
Details | Diff | Review

Description glen beasley 2007-10-31 19:33:25 PDT
cc -dynamiclib -compatibility_version 1 -current_version 1 -install_name @executable_path/libnssdbm3.dylib -headerpad_max_install_names  -o Darwin9.0.0_DBG.OBJ/libnssdbm3.dylib Darwin9.0.0_DBG.OBJ/dbmshim.o Darwin9.0.0_DBG.OBJ/keydb.o Darwin9.0.0_DBG.OBJ/lgattr.o Darwin9.0.0_DBG.OBJ/lgcreate.o Darwin9.0.0_DBG.OBJ/lgdestroy.o Darwin9.0.0_DBG.OBJ/lgfind.o Darwin9.0.0_DBG.OBJ/lginit.o Darwin9.0.0_DBG.OBJ/lgutil.o Darwin9.0.0_DBG.OBJ/lowcert.o Darwin9.0.0_DBG.OBJ/lowkey.o Darwin9.0.0_DBG.OBJ/pcertdb.o Darwin9.0.0_DBG.OBJ/pk11db.o   ../../../../../dist/Darwin9.0.0_DBG.OBJ/lib/libfreebl.a ../../../../../dist/Darwin9.0.0_DBG.OBJ/lib/libdbm.a  -L ../../../../../dist/Darwin9.0.0_DBG.OBJ/lib -lnssutil3 -L../../../../../dist/Darwin9.0.0_DBG.OBJ/lib -lplc4 -lplds4 -lnspr4  
ld: in ../../../../../dist/Darwin9.0.0_DBG.OBJ/lib, can't map file, errno=22
collect2: ld returned 1 exit status
make: *** [Darwin9.0.0_DBG.OBJ/libnssdbm3.dylib] Error 1



#define	EINVAL		22		/* Invalid argument */
Comment 1 glen beasley 2007-10-31 19:57:09 PDT
the problem is there is the white space after -L for 
-L ../../../../../dist/Darwin9.0.0_DBG.OBJ/lib -lnssutil3
Comment 2 glen beasley 2007-10-31 20:11:44 PDT
Created attachment 286927 [details] [diff] [review]
remove white space
Comment 3 Robert Relyea 2007-11-07 10:29:28 PST
Comment on attachment 286927 [details] [diff] [review]
remove white space

r+
Comment 4 glen beasley 2007-11-07 12:05:12 PST
/cvsroot/mozilla/security/nss/lib/softoken/legacydb/config.mk,v  <--  config.mk
new revision: 1.5; previous revision: 1.4
done

Note You need to log in before you can comment on or make changes to this bug.