SSL pages refuse to shrink under certain width

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
11 years ago
11 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

({regression})

Trunk
x86
Linux
regression
Points:
---
Bug Flags:
blocking-firefox3 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

11 years ago
2007-10-31 linux trunk nightly

SSL pages refuse to shrink under a certain width (the width of the navigation buttons + grey "verified" bit of the url + search bar). If you try shrinking the window under this width, content and other bits of chrome get cut off, even if they could shrink further.

This is basically identical to bug 328040 except it only happens for SSL pages. Unfortunately, that bug was fixed by "the new theme landing", which might not help.

I'm pretty sure this is a regression, though I don't often have my window small enough that it would occur so I don't know from when. My first guess would be whenever that extra little bit of chrome that verifies the identity was added.
Flags: blocking1.9?
This is likely the result of changes to the page itself, and not a layout bug, right?
Component: Layout → General
QA Contact: layout → general
(Reporter)

Comment 2

11 years ago
No, this is because of chrome, specifically the grey bit in the URL bar that only shows up when there's an SSL site. Also, it affects chrome (e.g. the tab bar) as well as page content.

Assuming that chrome shouldn't be able to make this happen, that makes this (I think) a layout bug, that if needed for the release could be worked around by changing the theme to not trigger it.

Note that the underlying layout bug has probably been around for a long time, probably since around when bug 328040 was filed, but it showing up on SSL pages is recent.
Component: General → Layout
QA Contact: general → layout
(In reply to comment #2)
> No, this is because of chrome, specifically the grey bit in the URL bar that
> only shows up when there's an SSL site. Also, it affects chrome (e.g. the tab
> bar) as well as page content.

"grey bit in the URL bar"? Do you mean the "identity box" that's attached to the  favicon?

> Assuming that chrome shouldn't be able to make this happen, that makes this (I
> think) a layout bug, that if needed for the release could be worked around by
> changing the theme to not trigger it.

I don't see why you would make that assumption. What makes you think this is a layout bug rather than a missing min-width?
Component: Layout → General
Flags: blocking1.9?
Product: Core → Firefox
QA Contact: layout → general
(Reporter)

Comment 4

11 years ago
(In reply to comment #3)

> > Assuming that chrome shouldn't be able to make this happen, that makes this (I
> > think) a layout bug, that if needed for the release could be worked around by
> > changing the theme to not trigger it.
> 
> I don't see why you would make that assumption. What makes you think this is a
> layout bug rather than a missing min-width?

Point taken, I guess I'm just a lot more used to filing layout bugs than firefox ones :)
Flags: blocking-firefox3?
(Reporter)

Comment 5

11 years ago
Created attachment 287260 [details]
Example screenshot
(Reporter)

Comment 6

11 years ago
Created attachment 287261 [details]
Example screenshot of normal operation

Note the many differences: in the SSL page the tabs don't shrink as far as they should (I have them set to shrink as small as they need) and the close button and the tab list button at the end are entirely cut off, the throbber in the top right isn't there, the vertical scrollbar in the content isn't there, and the horizontal scrollbar is cut off, even the bookmarks toolbar is wrong, as the dropdown at the right is gone.

Also note that with normal operation, the window is small enough that stuff on the navigation bar IS getting cut off, since it can't shrink any smaller. However, no other chrome or content is affected.
(Reporter)

Comment 7

11 years ago
Since bug 402260 was checked in, this is no longer visible. However, that bug "is a temp thing.  We need to decide whether we're doing this..." so this needs to stay open.
That screenshot doesn't really seem like something compelling, Bugzilla's layout doesn't shrink down that low....
This won't block Firefox 3's release in any case.
Flags: blocking-firefox3? → blocking-firefox3-
(Reporter)

Comment 10

11 years ago
(In reply to comment #8)
> That screenshot doesn't really seem like something compelling, Bugzilla's
> layout doesn't shrink down that low....

It's not the content that's the problem, it's the chrome. The vertical scrollbar is completely gone, and the horizontal is cut off, among many other problems.

Re-requesting blocking assuming it was denied on a faulty understanding of the problem. (If not, sorry, though some explanation of why missing chrome doesn't block would be good.)
Flags: blocking-firefox3- → blocking-firefox3?
Eventually chrome breaks if you resize way too small, this just makes that happen at a sooner point, from the look of this... I wouldn't block on "when I make the window really really small it doesn't look right" case, we've said no in the past on similar issues.  450 pixels is smaller than nearly any major site will reasonably support well, so its basically an edgecase.
Flags: blocking-firefox3? → blocking-firefox3-
(Reporter)

Comment 12

11 years ago
Created attachment 287543 [details]
My bank breaks at 600px

My bank breaks at 600px, which I sometimes resize my window to even though I have a 1600x1200 monitor. Banks tend to have long domain names, I've found a few that break even larger.

Also, note that when people resize their window that small, they expect to have to scroll. This, however, makes horizontal scrolling not work for the content on the side of the window, and vertical scrolling impossible for people who habitually use the scrollbar.

I won't push this any farther though.
(Reporter)

Comment 13

11 years ago
See also bug 403666, bug 312247.
(Reporter)

Comment 14

11 years ago
This was fixed at some point: it now resizes properly until only the tab overflow buttons and the tab close button (since I have browser.tabs.closebuttons = 3) are left, which is around 32 px.

I'm curious to know what fixed it, but for now, -> WFM
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.