[10.5] Cmd+L stops focusing the location bar

VERIFIED WORKSFORME

Status

()

Core
Widget: Cocoa
P1
normal
VERIFIED WORKSFORME
11 years ago
10 years ago

People

(Reporter: dcamp, Assigned: Josh Aas)

Tracking

Trunk
x86
Mac OS X
Points:
---
Bug Flags:
blocking1.9 +

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
Since installing leopard I've noticed that sometimes Cmd+L stops being handled correctly.

It's not a focus issue, clicking or tabbing to the location bar works fine.

Once I'm in this state, Cmd+L gives me:

###!!! ASSERTION: Carbon event for menu hit either not sent or not handled!: 'err == noErr', file ../../../../mozilla/widget/src/cocoa/nsMenuBarX.mm, line 1058
(Reporter)

Updated

11 years ago
Version: unspecified → Trunk
I don't see this using Tiger, so adding the 10.5 prefix so it can get tracked in our queries.
Summary: Cmd+L stops focusing the location bar → [10.5] Cmd+L stops focusing the location bar
I've seen it on Tiger, pretty sure.
Summary: [10.5] Cmd+L stops focusing the location bar → Cmd+L stops focusing the location bar
(In reply to comment #2)
> I've seen it on Tiger, pretty sure.

Are you sure it was this exact bug? I'm seeing this quite frequently now that I've upgraded to Leopard, and I don't remember ever seeing it before.
(In reply to comment #3)
> (In reply to comment #2)
> > I've seen it on Tiger, pretty sure.
> 
> Are you sure it was this exact bug? I'm seeing this quite frequently now that
> I've upgraded to Leopard, and I don't remember ever seeing it before.

I didn't see that assertion raised, no, so it could be something else. I'm not looking at assertions -- I probably should be.

(Reporter)

Updated

11 years ago
Flags: blocking1.9?
Marking as 10.5 since it is likely this is a 10.5 only bug (my comments above notwithstanding)
Summary: Cmd+L stops focusing the location bar → [10.5] Cmd+L stops focusing the location bar
Flags: blocking1.9? → blocking1.9+
Priority: -- → P1
(Assignee)

Comment 6

11 years ago
We really need reliable str for this, dropping to P2 until we figure something out. I have never seen this, I just tried to repro for a while.
Priority: P1 → P2
(Assignee)

Updated

11 years ago
Priority: P2 → P3
(Reporter)

Comment 7

11 years ago
I haven't seen this one since Josh landed some focus changes that he thought might affect this...
(Assignee)

Updated

11 years ago
Priority: P3 → P1
(Assignee)

Comment 8

11 years ago
Closing out on reports that this has gone away, particularly after the focus changes in bug 403232 landed.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
verified fixed using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b4pre) Gecko/2008020601 Firefox/3.0b4pre - can not reproduce the problem from comment #0 and also i don't see the assertion

Verified fixed
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.