Website certified by unknown authority

RESOLVED FIXED

Status

RESOLVED FIXED
11 years ago
4 years ago

People

(Reporter: Gaurav0, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.8) Gecko/20071008 Firefox/2.0.0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.8) Gecko/20071008 Firefox/2.0.0.8

When signing up for a new account at mynfbonline.com, taken to above url which then redirects to "Website certified by unknown authority". The website didn't provide a contact email address, so I called them at the provided phone number, 1-866-590-7098. Rather than addressing the issue, the customer representative asked me to "upgrade my browser to a browser that supports 128-bit encryption like Microsoft® Internet Explorer 5.0 or Netscape 4.08 or above" (paraphrasing, copied that from the "computer requirements" page on the website).

Reproducible: Always

Steps to Reproduce:
1. Go to mynfbonline.com
2. Click on "Sign Up for MyNFBOnline"
3. 
Actual Results:  
"Website certified by unknown authority" dialog.

Expected Results:  
Redirected to a secure sign-on page.

Website owned by Northfork Bank, subsidiary of Capital One.
(Reporter)

Comment 1

11 years ago
I am no longer having the issue that caused me to file this bug. However, I am concerned that a bank would not support me if I used Firefox. How should this be resolved?

Comment 2

11 years ago
Gaurav: do you have any problems logging in at

http://www.capitalone.com/bank/index.php?id=bank

where their online banking moved as of March 2008?

If not, I think it's safe to resolve this FIXED, or as a duplicate of bug 322286 if the new site is problematic.

Comment 3

11 years ago
FIXED per comment 2, since no response has been forthcoming.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.