If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

GMail file attachments with Cyrillic names screw up download manager

RESOLVED WORKSFORME

Status

()

Toolkit
Downloads API
RESOLVED WORKSFORME
10 years ago
6 years ago

People

(Reporter: Ihar Mahaniok, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.8.1.6) Gecko/20060201 Firefox/2.0.0.6 (Ubuntu-dapper)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.8.1.6) Gecko/20060201 Firefox/2.0.0.6 (Ubuntu-dapper)

I've got an e-mail with an attachment with Cyrillic name (specifically, "Календарь 07_08.zip") on my Gmail account. I click the link "Download", Firefox says "You have chosen to open "Календарь 07_08.zip", I click "Save".

Then, in Download Manager, I see the item with the name "0;5=40@L 07_08.zip". And it is saved to my disk under this 'nice' name.

If I then close Firefox, open it, and open Download Manager...

It shows a dialog without any files in it. And in the bottom, it says "All files downloaded to:", then a long empty space (but clickable; and if I click, nothing happens), and a "Clean Up" button. So, when I click on links that I wish to download, they are (generally) downloaded, but don't show up in Downloads dialog. 

If I go to Error Console, I see:

JSConsole shows this:
Error: not well-formed
Source File: file:///home/mahaniok/.mozilla/firefox/rrn3o1fu.default/downloads.rdf
Line: 842, Column: 36
Source Code:
 <RDF:Description RDF:about="/tmp/ 0;5=40@L
07_08.zip"-----------------------------------^

Error: uncaught exception: [Exception... "ServiceManager::GetService
returned failure code:"  nsresult: "0x80570016
(NS_ERROR_XPC_GS_RETURNED_FAILURE)"  location: "JS frame ::
chrome://mozapps/content/downloads/downloads.js :: Startup :: line
476"  data: no]


If I manually remove this file's entries from the downloads.rdf, Download Manager works just fine.

Reproducible: Always

Steps to Reproduce:
1. Create a file named "Календарь 07_08.zip" (without quotes)
2. Send an e-mail to your gmail account with this file attached
3. Open the message, click on "Download"
4. Save the file
5. Close Firefox
6. Open Firefox, go to Downloads Manager
Actual Results:  
Download manager

Expected Results:  
1. should save file under correct Cyrillic name
2. and should also show working Download Manager even if downloads.rdf has incorrect content


I checked Firefox on Windows, and there is no such problem on Windows - name is correct all the way.
Resolving old UNCONFIRMED Download Manager bugs as INCOMPLETE.  If you still see this issue, please reopen.

To mark all these bug changes as read, filter on ONOMATOPOEIA.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 2

10 years ago
still see it in 2.0.0.12.
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit

Comment 3

8 years ago
I experience what seems to be essentially the same problem in Firefox 3.6 on Windows 7. Please reopen this issue.

Comment 4

8 years ago
The status bar shows correct Cyrillic file names, but the download manager shows their ...ed up versions. By the way, Google Chrome does the same thing.
Do you still see this problem when using current release of firefox?
Whiteboard: [closeme 2011-12-15]

Comment 6

6 years ago
It is good in 11.0a1 (2011-11-23)
excellent.
thanks
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago6 years ago
Resolution: --- → WORKSFORME
Whiteboard: [closeme 2011-12-15]
You need to log in before you can comment on or make changes to this bug.