Reading an ical file shows error windows with "this.startDate has no properties"

VERIFIED DUPLICATE of bug 397559

Status

Calendar
Import and Export
--
major
VERIFIED DUPLICATE of bug 397559
10 years ago
10 years ago

People

(Reporter: Bruno Abele, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9
Build Identifier: Lightning 0.7 (2007102304) on Thunderbird Version 2.0.0.6 (20070728),  Sunbird Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.8pre) Gecko/20071023 Sunbird/0.7

Same file loaded with sunbird 0.5, lightning 0.5. With 0.7 version it failes. File  is created by MobileMaster.

Reproducible: Always

Steps to Reproduce:
1. Open attached Calender file cal.ics
2. Error windows appears
3. Same with calender refresh



Error details are:

[Exception... "'[JavaScript Error: "this.startDate has no properties" {file: "file:///C:/Dokumente%20und%20Einstellungen/babele/Anwendungsdaten/Thunderbird/Profiles/vazawsmx.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calEvent.js" line: 230}]' when calling method: [calIEvent::icalComponent]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: file:///C:/Dokumente%20und%20Einstellungen/babele/Anwendungsdaten/Thunderbird/Profiles/vazawsmx.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calIcsParser.js :: ip_parseString :: line 117"  data: yes]
(Reporter)

Comment 1

10 years ago
Created attachment 287082 [details]
Cal file created by Mobile master, cannot import on 0.7

The calender file that triggers the error

Comment 2

10 years ago
Confirmed on another machine. The attached ICS file triggers an error in sunbird 0.7, but NOT in 0.5

Comment 3

10 years ago
Duplicate of bug 397559?

Comment 4

10 years ago
The attached .ics file produces the same error in Sunbird 0.5 and Sunbird 0.7 as described in Bug 397559 Comment #3.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 397559
(Reporter)

Comment 5

10 years ago
Problem has a workaround, this is why it happened:

The ICS file was  created (with errors) by an older version of Mobile Master. Files from newer MM version are correct. But there was no visible error before Lightning 0.7.

When upgrading to MM 6.9.4 the error was not corrected during sync as the data (timestamps) did not change.

After removing the calender entries from the ics file and doing a resync the MM 6.9.4 wrote the entries with all needed properties and Lightning 0.7 works fine.

MM got an email to inform users on this update issue.

Thanks for your help. 

But: It would be great if the ics-parser showed the input file line number on parsing errors.

Updated

10 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.