When you save a file as 'text' Firefox appears to add a pipe | character to the start and end

RESOLVED DUPLICATE of bug 131166

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 131166
10 years ago
10 years ago

People

(Reporter: Chris, Unassigned)

Tracking

Trunk
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME, URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9

The page mentioned above has a simple HTML file containing the following code:

<html><head></head><body><code>test<br>test</code></body></html>

If you 'view source' you can confirm this.

If you save the page to disk as a text file (File -> Save Page As -> Text Files) then it saves the following:

|test
test|

The pipe characters should not be there as they are not in the original file.

Reproducible: Always

Steps to Reproduce:
See above
Actual Results:  
See above

Expected Results:  
See above
(Reporter)

Comment 1

10 years ago
Also happens with Minefield.

Only happens when you use the [code] tag.

See here: http://forums.mozillazine.org/viewtopic.php?p=3149681#3149681
Version: unspecified → Trunk

Comment 2

10 years ago
As I noted in the above thread this is by design.  

Certain tags preserve some of the formatting as an important part of the content in the form of extra delimiters.  

For example: <b> (delimited with *), <em> (delimited with *), <u> (with _), and in this case <code> (delimited with pipe |). 



Whiteboard: CLOSEME

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 131166
You need to log in before you can comment on or make changes to this bug.