Hit Counter doesn't display properly -- shows as "NoReferer"

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
10 years ago
7 years ago

People

(Reporter: Charles Brenner, Unassigned)

Tracking

2.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-07-30], URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9

Problem started happening recently (last few weeks?). Used to work just fine with Firefox.
Counter displays as expected with IE or Safari.
Verio is the internet provider. This problem exists with all my web counters.
Counter also does not update when page is loaded. (It should, and does with the other browsers.)
Alt text also does not appear.

Reproducible: Always

Steps to Reproduce:
1. Load the web page  http://dna-view.com/foo.htm
2. Examine the box at the bottom.
Actual Results:  
red-bordered box containing "NoReferer"

Expected Results:  
box with a number such as 000006

Comment 1

10 years ago
Works for me - Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9 and Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a9pre) Gecko/2007110103 Minefield/3.0a9pre

Comment 2

10 years ago
The spelling for the word NoReferer make me think that this related to the Referer HTTP header field, which is famously misspelled (it should be Referrer). 

It seems to me that the software behind the counter is complaining that no header field is found in the image request (part of a check to see that the counter is only used on the page where it's supposed to be used). That can be done by copying the URL of the image (<http://dna-view.com/counter?charset=neon>, NOT the html page !) to a new tab, as opposed to loading the page itself (which sets the Referer header).

When I do that, I see the error in the image (yellow letters on black, with a red border.

As an aside I see correct counter (I had number 10 thru 17) : if you always  see the same image, then you might have a problem with caching. It seems to me that you had the 'error' image once, and it's now cached, so it shows up on all your pages.
This bug was originally reported on Firefox 2.x or older, which is no longer supported and will not be receiving any more updates. I strongly suggest that you update to Firefox 3.6.6 or later, update your plugins (flash, adobe, etc.), and retest in a new profile. If you still see the issue with the updated Firefox, please post here. Otherwise, please close as RESOLVED > WORKSFORME
http://www.mozilla.com
http://support.mozilla.com/kb/Managing+profiles
http://support.mozilla.com/kb/Safe+mode
Whiteboard: [CLOSEME 2010-07-30]
Version: unspecified → 2.0 Branch
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.